Commit 3a34a237 authored by Xavier Chantry's avatar Xavier Chantry Committed by Brian Paul

fdo25614-genmipmap: Require OpenGL 1.3.

glActiveTexture is available only if the GL version is 1.3 or greater.
Signed-off-by: default avatarXavier Chantry <chantry.xavier@gmail.com>
Signed-off-by: Brian Paul's avatarBrian Paul <brianp@vmware.com>
parent 83182a86
......@@ -57,6 +57,11 @@ piglit_init(int argc, char **argv)
{
GLint alpha_bits;
if (!GLEW_VERSION_1_3) {
printf("Requires OpenGL 1.3\n");
piglit_report_result(PIGLIT_SKIP);
}
loadTex();
glGetIntegerv(GL_ALPHA_BITS, &alpha_bits);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment