Commit 44703217 authored by Jose Fonseca's avatar Jose Fonseca

scons: Refuse to use LLVM 2.7 for now.

LLVM's trunk is totally broken, at least for x86_64.

See http://www.llvm.org/bugs/show_bug.cgi?id=6429
parent 19a63331
......@@ -82,6 +82,11 @@ def generate(env):
print 'scons: could not determine the LLVM version from %s' % llvm_config
return
if llvm_version >= distutils.version.LooseVersion('2.7'):
print 'scons: Ignoring unsupported LLVM version %s' % llvm_version
print 'scons: See http://www.llvm.org/bugs/show_bug.cgi?id=6429'
return
env.Prepend(CPPPATH = [os.path.join(llvm_dir, 'include')])
env.AppendUnique(CPPDEFINES = [
'__STDC_LIMIT_MACROS',
......@@ -133,6 +138,11 @@ def generate(env):
llvm_version = env.backtick('llvm-config --version').rstrip()
llvm_version = distutils.version.LooseVersion(llvm_version)
if llvm_version >= distutils.version.LooseVersion('2.7'):
print 'scons: Ignoring unsupported LLVM version %s' % llvm_version
print 'scons: See http://www.llvm.org/bugs/show_bug.cgi?id=6429'
return
try:
env.ParseConfig('llvm-config --cppflags')
env.ParseConfig('llvm-config --libs jit interpreter nativecodegen bitwriter')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment