Commit 32502b0e authored by Vinson Lee's avatar Vinson Lee

scons: Use '-Wmissing-field-initializers' on GCC 4.0 and greater only.

parent 658fc753
......@@ -295,7 +295,6 @@ def generate(env):
# - http://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html
ccflags += [
'-Wall',
'-Wmissing-field-initializers',
'-Wno-long-long',
'-ffast-math',
'-fmessage-length=0', # be nice to Eclipse
......@@ -304,6 +303,10 @@ def generate(env):
'-Wmissing-prototypes',
'-std=gnu99',
]
if distutils.version.LooseVersion(ccversion) >= distutils.version.LooseVersion('4.0'):
ccflags += [
'-Wmissing-field-initializers',
]
if distutils.version.LooseVersion(ccversion) >= distutils.version.LooseVersion('4.2'):
ccflags += [
'-Werror=pointer-arith',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment