Commit 1481d054 authored by Dylan Baker's avatar Dylan Baker Committed by Vinson Lee

meson: Only error building gallium video without libdrm when the platform is drm

Fixes: 3b265f61
       ("meson: gallium media state trackers require libdrm with x11")
Closes: #1878Tested-by: Vinson Lee's avatarVinson Lee <vlee@freedesktop.org>
parent dcd2f26b
Pipeline #68264 passed with stages
in 16 minutes and 5 seconds
......@@ -1443,7 +1443,7 @@ if with_platform_x11
with_gallium_omx != 'disabled'))
dep_xcb = dependency('xcb')
dep_x11_xcb = dependency('x11-xcb')
if not dep_libdrm.found()
if with_dri_platform == 'drm' and not dep_libdrm.found()
error('libdrm required for gallium video statetrackers when using x11')
endif
endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment