radv: advertise VK_KHR_fragment_shader_barycentric on GFX10.3+

It can't be supported on older hardware because it's impossible to
determine the provoking vertex ID without LOAD_PROVOKING_VTX which is
GFX10.3+ only.

Closes: #6557
Signed-off-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
232 jobs for !16742 with radv_VK_KHR_fragment_shader_barycentric in 4 minutes and 55 seconds (queued for 49 minutes and 38 seconds)
merge request