Commit e550ca88 authored by Trevor Woerner's avatar Trevor Woerner Committed by Marge Bot
Browse files

docs/egl.rst: switch true→enabled



The old "true/false" values for some of the configuration options have been
deprecated in favour of enabled/disabled.
Signed-off-by: Trevor Woerner's avatarTrevor Woerner <twoerner@gmail.com>
Part-of: <mesa/mesa!8173>
parent 6a93a6e1
Pipeline #247593 passed with stages
in 2 minutes
...@@ -21,9 +21,9 @@ Build EGL ...@@ -21,9 +21,9 @@ Build EGL
.. code-block:: console .. code-block:: console
$ meson configure \ $ meson configure \
-D egl=true \ -D egl=enabled \
-D gles1=true \ -D gles1=enabled \
-D gles2=true \ -D gles2=enabled \
-D dri-drivers=... \ -D dri-drivers=... \
-D gallium-drivers=... -D gallium-drivers=...
...@@ -43,7 +43,7 @@ Configure Options ...@@ -43,7 +43,7 @@ Configure Options
There are several options that control the build of EGL at configuration There are several options that control the build of EGL at configuration
time time
``-D egl=true`` ``-D egl=enabled``
By default, EGL is enabled. When disabled, the main library and the By default, EGL is enabled. When disabled, the main library and the
drivers will not be built. drivers will not be built.
...@@ -60,11 +60,11 @@ time ...@@ -60,11 +60,11 @@ time
Unless for special needs, the build system should select the right Unless for special needs, the build system should select the right
platforms automatically. platforms automatically.
``-D gles1=true`` and ``-D gles2=true`` ``-D gles1=enabled`` and ``-D gles2=enabled``
These options enable OpenGL ES support in OpenGL. The result is one These options enable OpenGL ES support in OpenGL. The result is one
big internal library that supports multiple APIs. big internal library that supports multiple APIs.
``-D shared-glapi=true`` ``-D shared-glapi=enabled``
By default, ``libGL`` has its own copy of ``libglapi``. This options By default, ``libGL`` has its own copy of ``libglapi``. This options
makes ``libGL`` use the shared ``libglapi``. This is required if makes ``libGL`` use the shared ``libglapi``. This is required if
applications mix OpenGL and OpenGL ES. applications mix OpenGL and OpenGL ES.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment