Commit d442a992 authored by Christian Gmeiner's avatar Christian Gmeiner Committed by Marge Bot
Browse files

ci: sort packages installed via apt-get



Also remove duplicates.
Signed-off-by: Christian Gmeiner's avatarChristian Gmeiner <christian.gmeiner@gmail.com>
Reviewed-by: Michel Dänzer's avatarMichel Dänzer <mdaenzer@redhat.com>
Part-of: <!7553>
parent 87fb1ec3
Pipeline #227700 passed with stages
in 16 minutes and 56 seconds
......@@ -31,8 +31,8 @@ apt-get -y install \
python \
python3-mako \
python3-pil \
python3-requests \
python3-pip \
python3-requests \
python3-setuptools \
unzip \
wget \
......
......@@ -18,19 +18,19 @@ apt-get install -y --no-remove \
ccache \
cmake \
cpio \
g++ \
debootstrap \
fastboot \
flex \
g++ \
git \
netcat \
nginx-full \
pkg-config \
procps \
python3-distutils \
python3-minimal \
python3-serial \
python3.7 \
pkg-config \
procps \
rsync \
u-boot-tools \
unzip
......
......@@ -14,8 +14,8 @@ BAREMETAL_EPHEMERAL=" \
automake \
crossbuild-essential-$arch \
git-lfs \
libdrm-dev:$arch \
libboost-dev:$arch \
libdrm-dev:$arch \
libegl1-mesa-dev:$arch \
libelf-dev:$arch \
libexpat1-dev:$arch \
......@@ -28,10 +28,8 @@ BAREMETAL_EPHEMERAL=" \
libpython3-dev:$arch \
libstdc++6:$arch \
libtinfo-dev:$arch \
libegl1-mesa-dev:$arch \
libvulkan-dev:$arch \
libxcb-keysyms1-dev:$arch \
libpython3-dev:$arch \
python3-dev \
qt5-default \
qt5-qmake \
......
......@@ -60,11 +60,10 @@ fi
apt-get update
apt-get install -y automake \
git \
bc \
cmake \
wget \
debootstrap \
git \
libboost-dev \
libegl1-mesa-dev \
libgbm-dev \
......@@ -80,21 +79,22 @@ apt-get install -y automake \
python3-serial \
qt5-default \
qt5-qmake \
qtbase5-dev
qtbase5-dev \
wget
if [[ "$DEBIAN_ARCH" = "armhf" ]]; then
apt-get install -y libboost-dev:armhf \
libegl1-mesa-dev:armhf \
libelf-dev:armhf \
libgbm-dev:armhf \
libgles2-mesa-dev:armhf \
libpcre3-dev:armhf \
libpng-dev:armhf \
libpython3-dev:armhf \
libvulkan-dev:armhf \
libxcb-keysyms1-dev:armhf \
qtbase5-dev:armhf
apt-get install -y libegl1-mesa-dev:armhf \
libelf-dev:armhf \
libgbm-dev:armhf \
libgles2-mesa-dev:armhf \
libpcre3-dev:armhf \
libpng-dev:armhf \
libpython3-dev:armhf \
libvulkan-dev:armhf \
libxcb-keysyms1-dev:armhf \
libboost-dev:armhf \
qtbase5-dev:armhf
fi
############### Build dEQP runner
......
......@@ -35,8 +35,8 @@ apt-get install -y --no-remove \
gcc \
git \
kmod \
libclang-9-dev \
libclang-10-dev \
libclang-9-dev \
libclc-dev \
libelf-dev \
libepoxy-dev \
......@@ -59,8 +59,8 @@ apt-get install -y --no-remove \
libxvmc-dev \
libxxf86vm-dev \
libz-mingw-w64-dev \
llvm-9-dev \
llvm-10-dev \
llvm-9-dev \
pkg-config \
python-mako \
python3-mako \
......
......@@ -24,8 +24,8 @@ apt-get install -y --no-remove \
git \
git-lfs \
libexpat1 \
libllvm9 \
libllvm10 \
libllvm9 \
liblz4-1 \
libpcre32-3 \
libpng16-16 \
......@@ -34,8 +34,8 @@ apt-get install -y --no-remove \
libwayland-client0 \
libwayland-server0 \
libxcb-ewmh2 \
libxcb-randr0 \
libxcb-keysyms1 \
libxcb-randr0 \
libxcb-xfixes0 \
libxkbcommon0 \
libxrandr2 \
......
......@@ -37,14 +37,14 @@ STABLE_EPHEMERAL=" \
"
apt-get install -y --no-remove \
$STABLE_EPHEMERAL \
clinfo \
libclang-common-10-dev \
libclang-cpp10 \
libxcb-shm0 \
ocl-icd-libopencl1 \
python3-lxml \
python3-simplejson \
$STABLE_EPHEMERAL
python3-simplejson
. .gitlab-ci/container/container_pre_build.sh
......
......@@ -30,11 +30,11 @@ STABLE_EPHEMERAL=" \
# Unfortunately, gfxreconstruct needs the -dev packages:
# https://github.com/LunarG/gfxreconstruct/issues/402
apt-get install -y --no-remove \
$STABLE_EPHEMERAL \
libwayland-dev \
libx11-xcb-dev \
libxcb-keysyms1-dev \
libxcb1-dev \
$STABLE_EPHEMERAL
libxcb1-dev
# We need multiarch for Wine
dpkg --add-architecture i386
......
......@@ -11,7 +11,8 @@ elif [ $DEBIAN_ARCH = amd64 ]; then
echo "deb https://apt.llvm.org/buster/ llvm-toolchain-buster-10 main" >/etc/apt/sources.list.d/llvm10.list
apt-get update
ARCH_PACKAGES="libelf1
ARCH_PACKAGES="firmware-amd-graphics
libelf1
libllvm10
libxcb-dri2-0
libxcb-dri3-0
......@@ -19,29 +20,28 @@ elif [ $DEBIAN_ARCH = amd64 ]; then
libxcb-sync1
libxcb-xfixes0
libxshmfence1
firmware-amd-graphics
"
fi
apt-get -y install --no-install-recommends \
$ARCH_PACKAGES \
ca-certificates \
curl \
initramfs-tools \
libexpat1 \
libpng16-16 \
strace \
libpython3.7 \
libsensors5 \
libexpat1 \
libx11-6 \
libx11-xcb1 \
$ARCH_PACKAGES \
netcat-openbsd \
python3 \
libpython3.7 \
python3-pil \
python3-pytest \
python3-requests \
python3-yaml \
sntp \
strace \
wget \
xz-utils
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment