Commit bdd6147e authored by Emil Velikov's avatar Emil Velikov Committed by Emil Velikov

configure.ac: remove dummy radeon_gallium_llvm_check()

The extra function brings no added benefit as of earlier commit which
made llvm_require_version (as called by radeon_llvm_check) require LLVM
(--enable-gallium-llvm).

Fixes: 5f966a96af7 "configure.ac: Mandate --enable-gallium-llvm when
checking LLVM version"
Signed-off-by: default avatarEmil Velikov <emil.velikov@collabora.com>
Reviewed-by: default avatarTobias Droste <tdroste@gmx.de>
parent d4840c0c
...@@ -2225,13 +2225,6 @@ require_basic_egl() { ...@@ -2225,13 +2225,6 @@ require_basic_egl() {
esac esac
} }
radeon_gallium_llvm_check() {
if test "x$enable_gallium_llvm" != "xyes"; then
AC_MSG_ERROR([--enable-gallium-llvm is required when building $2])
fi
radeon_llvm_check $*
}
swr_require_cxx_feature_flags() { swr_require_cxx_feature_flags() {
feature_name="$1" feature_name="$1"
preprocessor_test="$2" preprocessor_test="$2"
...@@ -2296,7 +2289,7 @@ if test -n "$with_gallium_drivers"; then ...@@ -2296,7 +2289,7 @@ if test -n "$with_gallium_drivers"; then
PKG_CHECK_MODULES([RADEON], [libdrm >= $LIBDRM_RADEON_REQUIRED libdrm_radeon >= $LIBDRM_RADEON_REQUIRED]) PKG_CHECK_MODULES([RADEON], [libdrm >= $LIBDRM_RADEON_REQUIRED libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
require_libdrm "r600" require_libdrm "r600"
if test "x$enable_opencl" = xyes; then if test "x$enable_opencl" = xyes; then
radeon_gallium_llvm_check $LLVM_REQUIRED_R600 "r600" radeon_llvm_check $LLVM_REQUIRED_R600 "r600"
llvm_add_component "asmparser" "r600" llvm_add_component "asmparser" "r600"
llvm_add_component "bitreader" "r600" llvm_add_component "bitreader" "r600"
...@@ -2307,7 +2300,7 @@ if test -n "$with_gallium_drivers"; then ...@@ -2307,7 +2300,7 @@ if test -n "$with_gallium_drivers"; then
PKG_CHECK_MODULES([RADEON], [libdrm >= $LIBDRM_RADEON_REQUIRED libdrm_radeon >= $LIBDRM_RADEON_REQUIRED]) PKG_CHECK_MODULES([RADEON], [libdrm >= $LIBDRM_RADEON_REQUIRED libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
PKG_CHECK_MODULES([AMDGPU], [libdrm >= $LIBDRM_AMDGPU_REQUIRED libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED]) PKG_CHECK_MODULES([AMDGPU], [libdrm >= $LIBDRM_AMDGPU_REQUIRED libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED])
require_libdrm "radeonsi" require_libdrm "radeonsi"
radeon_gallium_llvm_check $LLVM_REQUIRED_RADEONSI "radeonsi" radeon_llvm_check $LLVM_REQUIRED_RADEONSI "radeonsi"
require_basic_egl "radeonsi" require_basic_egl "radeonsi"
;; ;;
xnouveau) xnouveau)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment