Commit 80817b6e authored by Jesse Natalie's avatar Jesse Natalie
Browse files

meson: Adjust Clover's required LLVM modules



When coming from CMake, all-targets doesn't exist, and Clover's
mechanism for finding Clang apparently requires the OpenMP frontend
lib but doesn't automatically pull it in.
Reviewed-by: Daniel Stone's avatarDaniel Stone <daniels@collabora.com>
Part-of: <!7680>
parent 959e0177
......@@ -1479,9 +1479,10 @@ if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
endif
if with_gallium_opencl
llvm_modules += [
'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
'lto', 'option', 'objcarcopts', 'profiledata',
'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
'lto', 'option', 'objcarcopts', 'profiledata'
]
llvm_optional_modules += ['frontendopenmp']
endif
if with_microsoft_clc
llvm_modules += ['target', 'linker', 'irreader', 'option', 'libdriver']
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment