Commit 708db983 authored by Emmanuel Vadot's avatar Emmanuel Vadot Committed by Marge Bot

meson: Do not enable USE_ELF_TLS for FreeBSD

Compiling with this option result in too much TLS usage and FreeBSD
cannot handle that.
Reviewed-by: Eric Engestrom's avatarEric Engestrom <eric@engestrom.ch>
Signed-off-by: Emmanuel Vadot's avatarEmmanuel <manu@FreeBSD.org>
Part-of: <!3559>
parent 6cba468b
......@@ -422,7 +422,7 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
if host_machine.system() != 'windows' and (not with_platform_android or get_option('platform-sdk-version') >= 29)
if not ['windows', 'freebsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
pre_args += '-DUSE_ELF_TLS'
endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment