Commit 22439f24 authored by Dave Airlie's avatar Dave Airlie

st/mesa: add option to enable GLSL 1.40

Allow GLSL 1.40 to be enabled if the driver advertises it.
Signed-off-by: default avatarDave Airlie <airlied@redhat.com>
parent 915efe7f
......@@ -553,7 +553,12 @@ void st_init_extensions(struct st_context *st)
/* Figure out GLSL support. */
glsl_feature_level = screen->get_param(screen, PIPE_CAP_GLSL_FEATURE_LEVEL);
if (glsl_feature_level >= 130) {
if (glsl_feature_level >= 140) {
if (ctx->API == API_OPENGL_CORE)
ctx->Const.GLSLVersion = 140;
else
ctx->Const.GLSLVersion = 130;
} else if (glsl_feature_level >= 130) {
ctx->Const.GLSLVersion = 130;
} else {
ctx->Const.GLSLVersion = 120;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment