Commit a2801ef9 authored by Olivier Crête's avatar Olivier Crête 👻

Version 0.1.5

parent 90ceccbd
libnice 0.1.5 (2014-03-06)
==========================
API: nice_agent_recv() and nice_agent_recv_nonblocking() as an alternative to
the nice_agent_attach_recv()
API: nice_agent_recv_messages() and nice_agent_recv_messages_nonblocking() to
receive multiple messages at the same time
API: nice_agent_get_io_stream() to get a GIOStream in reliable mode
API: nice_agent_get_selected_socket() to extract the selected GSocket
Import Google's newer PseudoTCP code including window scaling
Improve PseudoTCP performance
Improve performance
Build fixes
libnice 0.1.4 (2013-02-22) libnice 0.1.4 (2013-02-22)
========================== ==========================
......
...@@ -5,7 +5,7 @@ dnl Always compile with -Wall; if --enable-compile-warnings=error is passed, ...@@ -5,7 +5,7 @@ dnl Always compile with -Wall; if --enable-compile-warnings=error is passed,
dnl also use -Werror. git and pre-releases default to -Werror dnl also use -Werror. git and pre-releases default to -Werror
dnl use a three digit version number for releases, and four for cvs/prerelease dnl use a three digit version number for releases, and four for cvs/prerelease
AC_INIT([libnice],[0.1.4.1]) AC_INIT([libnice],[0.1.5])
LIBNICE_RELEASE="no" LIBNICE_RELEASE="no"
AC_CANONICAL_TARGET AC_CANONICAL_TARGET
...@@ -39,9 +39,9 @@ AC_CONFIG_FILES([ ...@@ -39,9 +39,9 @@ AC_CONFIG_FILES([
# Increment CURRENT and AGE. Set REVISION to 0 # Increment CURRENT and AGE. Set REVISION to 0
# If there was an incompatible interface change: # If there was an incompatible interface change:
# Increment CURRENT. Set AGE and REVISION to 0 # Increment CURRENT. Set AGE and REVISION to 0
LIBNICE_CURRENT=12 LIBNICE_CURRENT=13
LIBNICE_REVISION=0 LIBNICE_REVISION=0
LIBNICE_AGE=2 LIBNICE_AGE=3
LIBNICE_LIBVERSION=${LIBNICE_CURRENT}:${LIBNICE_REVISION}:${LIBNICE_AGE} LIBNICE_LIBVERSION=${LIBNICE_CURRENT}:${LIBNICE_REVISION}:${LIBNICE_AGE}
LIBNICE_LT_LDFLAGS="-version-info ${LIBNICE_LIBVERSION} -no-undefined" LIBNICE_LT_LDFLAGS="-version-info ${LIBNICE_LIBVERSION} -no-undefined"
AC_SUBST(LIBNICE_LT_LDFLAGS) AC_SUBST(LIBNICE_LT_LDFLAGS)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment