Commit 5b2d065e authored by Akira TAGOH's avatar Akira TAGOH
Browse files

Bug 34266 - configs silently ignored if libxml2 doesn't support SAX1 interface

Check if libxml2 has built with --with-sax1
parent 9c377192
......@@ -353,6 +353,18 @@ if test "$enable_libxml2" = "yes"; then
AC_SUBST(LIBXML2_CFLAGS)
AC_SUBST(LIBXML2_LIBS)
fc_saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $LIBXML2_CFLAGS"
AC_MSG_CHECKING([SAX1 support in libxml2])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
#include <libxml/xmlversion.h>
#if !defined(LIBXML_SAX1_ENABLED)
# include "error: No SAX1 support in libxml2"
#endif
]])], [AC_MSG_RESULT([found])], [AC_MSG_ERROR([
*** SAX1 support in libxml2 is required. enable it or use expat instead.])])
CFLAGS="$fc_saved_CFLAGS"
fi
#
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment