1. 02 Feb, 2014 1 commit
    • Allison Lortie's avatar
      Add support for disabling some sources · c94e9cc8
      Allison Lortie authored
      Introduce configure options --disable-wifi-source, --disable-3g-source
      and --disable-modem-gps-source to allow disabling of backends that
      depend on NetworkManager and ModemManager (since these components are
      not widely ported).
      
      There is no "auto detect" -- the options must be explicitly specified in
      order to disable the feature.  This prevents a quiet reduction in
      functionality just because the right headers didn't happen to be
      installed at configure time, which should help prevent packaging
      mistakes.
      
      https://bugs.freedesktop.org/show_bug.cgi?id=73961
      c94e9cc8
  2. 30 Jan, 2014 1 commit
  3. 29 Jan, 2014 1 commit
    • Zeeshan Ali's avatar
      Move public API to a subdir · 44348a53
      Zeeshan Ali authored
      This is so that we can just point our docs to that directory and it
      doesn't complain about all the internal API that we don't want it to
      scan anyway. Currently without this patch, the build actually breaks on
      doc system parsing the internalized geocode-glib sources.
      44348a53
  4. 28 Jan, 2014 3 commits
  5. 26 Jan, 2014 1 commit
  6. 25 Jan, 2014 1 commit
  7. 24 Jan, 2014 1 commit
  8. 23 Jan, 2014 1 commit
    • Zeeshan Ali's avatar
      Import all geocode-glib sources · e8c8fc35
      Zeeshan Ali authored
      Instead of just importing geocode-location, we now import all its
      sources into a subdir. Not only latest geocode-location needs a few
      other files but also is the fact that we'll likely need to use more of
      geocode-glib API in geoclue.
      
      This commit also updates geocode-location.
      e8c8fc35
  9. 19 Jan, 2014 1 commit
  10. 17 Jan, 2014 1 commit
  11. 13 Jan, 2014 2 commits
  12. 11 Jan, 2014 1 commit
  13. 08 Jan, 2014 1 commit
  14. 04 Dec, 2013 1 commit
  15. 06 Oct, 2013 1 commit
  16. 26 Sep, 2013 3 commits
  17. 23 Sep, 2013 2 commits
  18. 18 Sep, 2013 1 commit
  19. 17 Sep, 2013 2 commits
    • Zeeshan Ali's avatar
      automake: Disable portability warnings · 6f36858c
      Zeeshan Ali authored
      When they are enabled, autogen.sh fails with loads of warnings on F19.
      
      -Wportability used to be automatically disabled with automake <= 1.12
      when using silent rules, but this is no longer the case with automake
      1.13 which is what fedora 19 uses:
      
      http://www.flameeyes.eu/autotools-mythbuster/automake/silent.html
      
      "As of version 1.13, though, this opt-in is no longer necessary, as all
      the Makefiles are generated to support them. The silent-rules option is
      now a no-op, doing nothing at all, in particular not silencing the
      portability warnings."
      
      This commit disables these warnings in order to avoid autogen.sh
      breakage because of the use of -Werror, they can be reenabled once
      gtk-doc.make is fixed to avoid these portability warnings.
      
      This patch and commit log is based on a patch from Christophe Fergeau
      <cfergeau@redhat.com> to spice-gtk.
      6f36858c
    • Zeeshan Ali's avatar
      Release 1.99.4 · dadb9fc7
      Zeeshan Ali authored
      dadb9fc7
  20. 09 Sep, 2013 1 commit
  21. 05 Sep, 2013 1 commit
  22. 04 Sep, 2013 1 commit
  23. 03 Sep, 2013 2 commits
  24. 25 Aug, 2013 1 commit
  25. 23 Aug, 2013 2 commits
  26. 20 Aug, 2013 2 commits
  27. 17 Aug, 2013 1 commit
    • Zeeshan Ali's avatar
      Require geoip >= 1.5.1 · 38d489a4
      Zeeshan Ali authored
      This is the latest version that adds the pkconfig file that we check
      for so in reality this is not a bump of our dependency.
      38d489a4
  28. 16 Aug, 2013 1 commit
    • Zeeshan Ali's avatar
      Import geoip code from geocode-glib · 2ce41f92
      Zeeshan Ali authored
      geocode-glib is meant to only do (reverse-)geocoding and all geolocation
      code belongs to us.
      
      This means we now drop our geocode-glib dep and instead directly depend
      on:
      
      json-glib-1.0 >= 0.14
      libsoup-2.4
      geoip (Only needed by geoip server)
      2ce41f92
  29. 05 Aug, 2013 1 commit
  30. 04 Aug, 2013 1 commit