build: glx: Lower gl version to work with libglvnd

When using mesa with libglvnd support, mesa will no longer install the
gl, glx, egl pkg-config files but instead let libglvnd provide them.
libglvnd maintainers decided to change the versioning as it was
mesa-specific previously. Now the libraries have versions of the API
they expose[1].
This causes problems when building the X server:

  checking for glproto >= 1.4.17 gl >= 9.2.0... no
  configure: error: Package requirements (glproto >= 1.4.17 gl >= 9.2.0) were not met:

  Requested 'gl >= 9.2.0' but version of gl is 1.2

Lower the version requirement to 1.2 to allow building against libglvnd
provided libraries

[1] https://github.com/NVIDIA/libglvnd/commit/0dfaea2bcb7cdcc785f95e244223bd004a2d7fba
3 jobs for build-libglvnd-gl-version in 7 minutes and 25 seconds
Status Job ID Name Coverage
  Docker Image
passed debian-testing #714269

00:00:41

 
  Build And Test
passed autotools-build-and-test #714270

00:06:43

passed meson-build-and-test #714271

00:02:14