Commit 6972e7a9 authored by Igor Rondarev's avatar Igor Rondarev Committed by Sebastian Dröge
Browse files

configure: Check for socketpair() in -lsocket too

On e.g. QNX it is in an external library, not libc.

https://bugzilla.gnome.org/show_bug.cgi?id=754875
parent eb884862
......@@ -620,6 +620,14 @@ AC_CHECK_FUNCS([poll])
AC_CHECK_FUNCS([ppoll])
AC_CHECK_FUNCS([pselect])
dnl check for socketpair()
AC_CHECK_FUNC(socketpair, [], [
AC_CHECK_LIB(socket, socketpair, [
SOCKET_LIBS="-lsocket"
AC_SUBST(SOCKET_LIBS)
])
])
dnl ****************************************
dnl *** GLib POLL* compatibility defines ***
dnl ****************************************
......
......@@ -151,6 +151,7 @@ libgstreamer_@GST_API_VERSION@_la_LIBADD = \
$(GST_PRINTF_LA) \
$(GST_ALL_LIBS) \
$(WIN32_LIBS) \
$(SOCKET_LIBS) \
$(LIBM)
libgstreamer_@GST_API_VERSION@_la_LDFLAGS = \
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment