Commit 10d90129 authored by Tim-Philipp Müller's avatar Tim-Philipp Müller

gst: suppress some more deprecated thread api until we fix it up

Which should be soon, since we already depend on an unstable glib for -base.
parent 75eb4fe9
......@@ -26,6 +26,9 @@
*
*/
/* FIXME 0.11: suppress warnings for deprecated API such as GStaticRecMutex
* with newer GLib versions (>= 2.31.0) */
#define GLIB_DISABLE_DEPRECATION_WARNINGS
#include "gst_private.h"
#include "glib-compat-private.h"
......
......@@ -63,7 +63,13 @@
* Last reviewed on 2011-06-08 (0.11.0)
*/
#ifdef HAVE_CONFIG_H
#include "config.h"
#endif
/* FIXME 0.11: suppress warnings for deprecated API such as GStaticRecMutex
* with newer GLib versions (>= 2.31.0) */
#define GLIB_DISABLE_DEPRECATION_WARNINGS
#include "gst_private.h"
#include "gstmemory.h"
......
......@@ -25,6 +25,9 @@
*
* Last reviewed on December 17th, 2009 (0.10.26)
*/
/* FIXME 0.11: suppress warnings for deprecated API such as GStaticRecMutex
* with newer GLib versions (>= 2.31.0) */
#define GLIB_DISABLE_DEPRECATION_WARNINGS
#include "gst_private.h"
#include "gstbuffer.h"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment