platform: use switch statement in _linktype_get_type() for better readability...

platform: use switch statement in _linktype_get_type() for better readability some if statements are redundant, use switch instead of it.
56 jobs for main in 46 minutes and 4 seconds (queued for 5 seconds)
latest