Commit 5fb25117 authored by Olivier Crête's avatar Olivier Crête 👻

version 0.1.17

parent c27f533e
Pipeline #150455 failed with stages
in 6 minutes and 42 seconds
libnice 0.1.17 (2020-05-21)
libnice 0.1.17 (2020-05-22)
===========================
Add API to retrieve the underlying BSD sockets
Support systems with multiple loopback devices
Ignore non-running network interfaces
Ignore multiple interface prefixes
Now tries to nominate matching pairs across components and streams
Retry TURN deallocation on timeout, requires not destoying the NiceAgent right after the stream
Use different port for every host candidate
Make timeouts and retransmissions more in line with the RFCs
Find OpenSSL without pkg-config, for Windows
Complete meson support
GLib required version update to 2.54
Removed deprecated GLib APIs
Many ICE compatibility and performance improvements
Many bug fixes
libnice 0.1.16 (2019-05-09)
===========================
......
......@@ -5,8 +5,8 @@ dnl Always compile with -Wall; if --enable-compile-warnings=error is passed,
dnl also use -Werror. git and pre-releases default to -Werror
dnl use a three digit version number for releases, and four for cvs/prerelease
AC_INIT([libnice],[0.1.16.1])
LIBNICE_RELEASE="no"
AC_INIT([libnice],[0.1.17])
LIBNICE_RELEASE="yes"
AC_CANONICAL_TARGET
......@@ -39,9 +39,9 @@ AC_CONFIG_FILES([
# Increment CURRENT and AGE. Set REVISION to 0
# If there was an incompatible interface change:
# Increment CURRENT. Set AGE and REVISION to 0
LIBNICE_CURRENT=19
LIBNICE_CURRENT=20
LIBNICE_REVISION=0
LIBNICE_AGE=9
LIBNICE_AGE=10
LIBNICE_LIBVERSION=${LIBNICE_CURRENT}:${LIBNICE_REVISION}:${LIBNICE_AGE}
LIBNICE_LT_LDFLAGS="-version-info ${LIBNICE_LIBVERSION} -no-undefined"
AC_SUBST(LIBNICE_LT_LDFLAGS)
......
project('libnice', 'c',
version: '0.1.16.1',
version: '0.1.17',
meson_version : '>= 0.52',
default_options : ['warning_level=1', 'buildtype=debugoptimized'])
......@@ -15,8 +15,12 @@ else
endif
# maintain compatibility with the previous libtool versioning
# libversion has 3 parts A.B.C
# A is the ABI version, change it if the ABI is broken, changing it resets B and C to 0. It matches soversion
# B is the ABI age, change it on new APIs that don't break existing ones, changing it resets C to 0
# C is the revision, change on new updates that don't change APIs
soversion = 10
libversion = '10.9.0'
libversion = '10.10.0'
glib_req = '>= 2.54'
gnutls_req = '>= 2.12.0'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment