build: Bump GLib dependency to 2.50 and add guards

libfprint already uses G_DEBUG_HERE in a lot of places which requires
GLib 2.50. Also add the appropriate defines so that usage of newer API
will result in warnings.
2 jobs for benzea/cleanups in 6 minutes and 37 seconds (queued for 14 minutes and 56 seconds)
Status Job ID Name Coverage
  Build
passed #357355
build

00:03:06

 
  Test
passed #357356
flatpak master

00:03:30