Commit fa56a379 authored by Kenneth Graunke's avatar Kenneth Graunke

gallium: Drop lower_fmod64 from drivers that don't support doubles.

Neither freedreno nor nv50 expose PIPE_CAP_DOUBLES, so there's no
fmod64 to be lowered.
Reviewed-by: default avatarMarek Olšák <marek.olsak@amd.com>
parent e8a60e5d
......@@ -41,7 +41,6 @@ static const nir_shader_compiler_options options = {
.lower_flrp64 = true,
.lower_ffract = true,
.lower_fmod32 = true,
.lower_fmod64 = true,
.lower_fdiv = true,
.lower_isign = true,
.lower_ldexp = true,
......@@ -67,7 +66,6 @@ static const nir_shader_compiler_options options_a6xx = {
.lower_flrp64 = true,
.lower_ffract = true,
.lower_fmod32 = true,
.lower_fmod64 = true,
.lower_fdiv = true,
.lower_isign = true,
.lower_ldexp = true,
......
......@@ -882,7 +882,6 @@ static const nir_shader_compiler_options nir_options = {
.lower_flrp32 = true,
.lower_flrp64 = true,
.lower_fpow = false,
.lower_fmod64 = true,
.lower_uadd_carry = true,
.lower_usub_borrow = true,
.lower_ffract = true,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment