glsl: do not use deprecated bison-keyword

%error-verbose has been deprecated since Bison 3.0, which was released
in 2013. In Bison 3.3.1 which was recently released, this has started
causing warnings. Let's update the code to do this in the modern way
intead, to avoid cluttering the output needlessly.

Signed-off-by: Erik Faye-Lund <erik.faye-lund@collabora.com>
Reviewed-by: Timothy Arceri <tarceri@itsqueeze.com>
10 jobs for !917 with bison-3.0-warning in 9 minutes and 59 seconds (queued for 2 seconds)
detached
Status Name Job ID Coverage
  Containers Build
passed debian #309921

00:00:21

 
  Build+Test
passed meson-clang #309923

00:08:44

passed meson-clover #309927

00:08:19

passed meson-main #309926

00:05:46

passed meson-swr-glvnd #309922

00:06:30

passed meson-vulkan #309928

00:02:35

passed scons-llvm #309930

00:06:24

passed scons-nollvm #309929

00:06:00

passed scons-swr #309924

00:05:53

passed scons-win64 #309925

00:09:36