Commit 6c364ec3 authored by Simon McVittie's avatar Simon McVittie
Browse files

Require pkg-config 0.28, for PKG_PROG_PKG_CONFIG



Signed-off-by: Simon McVittie's avatarSimon McVittie <smcv@collabora.com>
parent 32ccd075
......@@ -21,7 +21,7 @@
# SOFTWARE.
sudo: required
dist: trusty
dist: xenial
language: c
script:
- ./tools/ci-install.sh
......@@ -30,7 +30,6 @@ script:
env:
- ci_variant=production
- ci_variant=debug
- ci_docker=ubuntu:xenial ci_distro=ubuntu ci_suite=xenial
- ci_docker=debian:jessie-slim ci_distro=debian ci_suite=jessie
- ci_docker=debian:stretch-slim ci_distro=debian ci_suite=stretch
......
......@@ -9,6 +9,10 @@ Bugzilla bugs (indicated by "fd.o #nnn") to Gitlab issues
("dbus-glib#nnn") and merge requests ("dbus-glib!nnn"). See README and
CONTRIBUTING.md for more details.
Dependencies:
• pkg-config 0.28 is required when building from git
Enhancements:
• Rewrite CONTRIBUTING.md document, based on Wayland's equivalent
......
......@@ -42,6 +42,8 @@ AC_SUBST(LT_CURRENT)
AC_SUBST(LT_REVISION)
AC_SUBST(LT_AGE)
m4_ifndef([PKG_PROG_PKG_CONFIG],
[pkg.m4 version 0.28 or later is required])
AC_PROG_CC
AC_ISC_POSIX
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment