Commit 92b621ab authored by George Kiagiadakis's avatar George Kiagiadakis
Browse files

systemd: use the older version of the systemd pkgconfig variables

For compatibility with older versions of systemd
parent 9e7f3d47
......@@ -7,7 +7,7 @@ if systemd.found()
# system service
if get_option('systemd-system-service')
systemd_system_unit_dir = systemd.get_pkgconfig_variable(
'systemd_system_unit_dir',
'systemdsystemunitdir',
define_variable : ['prefix', get_option('prefix')])
if get_option('systemd-system-unit-dir') != ''
......@@ -20,7 +20,7 @@ if systemd.found()
# user service
if get_option('systemd-user-service')
systemd_user_unit_dir = systemd.get_pkgconfig_variable(
'systemd_user_unit_dir',
'systemduserunitdir',
define_variable : ['prefix', get_option('prefix')])
if get_option('systemd-user-unit-dir') != ''
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment