meson: Bump requirement to meson-0.52.0

Bumped in response to warning from meson:

    WARNING: Project specifies a minimum meson_version '>= 0.47.0' but uses features which were added in newer versions:
        * 0.50.0: {'install arg in configure_file'}

Even though there is no warning, we need 0.52.0 for include_type (added in 8264b51e) per:
    https://mesonbuild.com/Reference-manual_functions.html#arguments17
4 jobs for meson-bump-required-0.50 in 2 minutes and 34 seconds (queued for 1 second)