Commit bcff35ad authored by Thomas Vander Stichele's avatar Thomas Vander Stichele
Browse files

spec changes a gogo

Original commit message from CVS:
spec changes a gogo
parent d4f4eaba
%define prefix /usr
%define sysconfdir /etc
Docdir: %{prefix}/doc
Prefix: %prefix
Summary: GStreamer Streaming-media framework plugins
Name: gstreamer-plugins
Version: @VERSION@
Release: @GST_PLUGINS_RELEASE@
Summary: GStreamer Streaming-media framework plug-ins.
%define prefix /usr
%define sysconfdir /etc
Docdir: %{prefix}/share/doc
Prefix: %prefix
License: LGPL
Group: Libraries/Multimedia
Source: gst-plugins-%{version}.tar.gz
License: LGPL
URL: http://gstreamer.net/
Vendor: GStreamer Backpackers Team <package@gstreamer.net>
Source: http://gstreamer.net/releases/%{version}/src/gst-plugins-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%define _glib2 @GLIB2_REQ@
......@@ -27,20 +29,7 @@ operate on media data. Applications using this library can do anything
from real-time sound processing to playing videos, and just about anything
else media-related. Its plugin-based architecture means that new data
types or processing capabilities can be added simply by installing new
plugins.
%files
%defattr(-, root, root)
%doc AUTHORS COPYING README
%{_bindir}/gst-launch-ext
%{_bindir}/gst-visualise
%{_mandir}/man1/gst-launch-ext.*
%{_mandir}/man1/gst-visualise.1.*
%{_libdir}/gst/libgstaudioscale*
%{_libdir}/gst/libgstaudio.*
%{_libdir}/gst/libgstidct*
%{_libdir}/gst/libgstriff*
%{_libdir}/gst/libgstresample*
plug-ins.
%prep
%setup -n gst-plugins-%{version}
......@@ -94,467 +83,645 @@ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
%clean
[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%doc AUTHORS COPYING README
%{_bindir}/gst-launch-ext
%{_bindir}/gst-visualise
%{_mandir}/man1/gst-launch-ext.*
%{_mandir}/man1/gst-visualise.1.*
%{_libdir}/gst/libgstaudioscale.so
%{_libdir}/gst/libgstaudio.so
%{_libdir}/gst/libgstidct.so
%{_libdir}/gst/libgstresample.so
%{_libdir}/gst/libgstriff.so
%package -n gstreamer-plugins-devel
Summary: GStreamer Plugin Library Headers.
Group: Libraries/Multimedia
Requires: gstreamer-plugins >= %{version}
%description -n gstreamer-plugins-devel
GStreamer support libraries header files.
%files -n gstreamer-plugins-devel
%defattr(-, root, root)
%{_includedir}/gst/audio/audio.h
%{_includedir}/gst/idct/idct.h
%{_includedir}/gst/resample/resample.h
%{_includedir}/gst/riff/riff.h
# Here are all the packages depending on external libs #
### A52DEC ###
@USE_A52DEC_TRUE@%package -n gstreamer-a52dec
@USE_A52DEC_TRUE@Summary: GStreamer VOB decoder plugin
@USE_A52DEC_TRUE@Group: Libraries/Multimedia
@USE_A52DEC_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_A52DEC_TRUE@Requires: a52dec >= 0.7.3
@USE_A52DEC_TRUE@Summary: GStreamer VOB decoder plug-in.
@USE_A52DEC_TRUE@Group: Libraries/Multimedia
@USE_A52DEC_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_A52DEC_TRUE@Requires: a52dec >= 0.7.3
@USE_A52DEC_TRUE@BuildRequires: a52dec-devel >= 0.7.3
@USE_A52DEC_TRUE@
@USE_A52DEC_TRUE@%description -n gstreamer-a52dec
@USE_A52DEC_TRUE@Plugin for decoding of VOB files
@USE_A52DEC_TRUE@Plug-in for decoding of VOB files.
@USE_A52DEC_TRUE@
@USE_A52DEC_TRUE@%files -n gstreamer-a52dec
@USE_A52DEC_TRUE@%defattr(-, root, root)
@USE_A52DEC_TRUE@%{_libdir}/gst/libgsta52dec*
@USE_A52DEC_TRUE@%{_libdir}/gst/libgstac3parse*
@USE_A52DEC_TRUE@%{_libdir}/gst/libgsta52dec.so
@USE_A52DEC_TRUE@%{_libdir}/gst/libgstac3parse.so
@USE_A52DEC_TRUE@
@USE_A52DEC_TRUE@%post -n gstreamer-a52dec
@USE_A52DEC_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_A52DEC_TRUE@
@USE_A52DEC_TRUE@%postun -n gstreamer-a52dec
@USE_A52DEC_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### AALIB ###
@USE_AALIB_TRUE@%package -n gstreamer-aalib
@USE_AALIB_TRUE@Summary: GStreamer plugin for Ascii-art output
@USE_AALIB_TRUE@Group: Libraries/Multimedia
@USE_AALIB_TRUE@Requires: aalib >= 1.3
@USE_AALIB_TRUE@Summary: GStreamer plug-in for Ascii-art output.
@USE_AALIB_TRUE@Group: Libraries/Multimedia
@USE_AALIB_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_AALIB_TRUE@Requires: aalib >= 1.3
@USE_AALIB_TRUE@BuildRequires: aalib-devel >= 1.3
@USE_AALIB_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_AALIB_TRUE@
@USE_AALIB_TRUE@%description -n gstreamer-aalib
@USE_AALIB_TRUE@Plugin for viewing movies in Ascii-art using aalib library.
@USE_AALIB_TRUE@Plug-in for viewing video in Ascii-art using aalib library.
@USE_AALIB_TRUE@
@USE_AALIB_TRUE@%files -n gstreamer-aalib
@USE_AALIB_TRUE@%defattr(-, root, root)
@USE_AALIB_TRUE@%{_libdir}/gst/libgstaasink*
@USE_AALIB_TRUE@%{_libdir}/gst/libgstaasink.so
@USE_AALIB_TRUE@
@USE_AALIB_TRUE@%post -n gstreamer-aalib
@USE_AALIB_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_AALIB_TRUE@
@USE_AALIB_TRUE@%postun -n gstreamer-aalib
@USE_AALIB_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### ALSA ###
@USE_ALSA_TRUE@%package -n gstreamer-alsa
@USE_ALSA_TRUE@Summary: GStreamer plugins for the ALSA sound architecture
@USE_ALSA_TRUE@Group: Libraries/Multimedia
@USE_ALSA_TRUE@Summary: GStreamer plug-ins for the ALSA sound system.
@USE_ALSA_TRUE@Group: Libraries/Multimedia
@USE_ALSA_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_ALSA_TRUE@
@USE_ALSA_TRUE@%description -n gstreamer-alsa
@USE_ALSA_TRUE@Input and output plugin for the ALSA soundcard driver architecture. This plugin depends on Alsa 0.9.x or higher.
@USE_ALSA_TRUE@Input and output plug-in for the ALSA soundcard driver system.
@USE_ALSA_TRUE@This plug-in depends on Alsa 0.9.x or higher.
@USE_ALSA_TRUE@
@USE_ALSA_TRUE@%files -n gstreamer-alsa
@USE_ALSA_TRUE@%defattr(-, root, root)
@USE_ALSA_TRUE@%{_libdir}/gst/libgstalsa*
@USE_ALSA_TRUE@%{_libdir}/gst/libgstalsa.so
@USE_ALSA_TRUE@
@USE_ALSA_TRUE@%post -n gstreamer-alsa
@USE_ALSA_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### ARTSD SOUND SERVER ###
@USE_ARTSC_TRUE@%package -n gstreamer-artsd
@USE_ARTSC_TRUE@Summary: GStreamer artsd output plugin
@USE_ARTSC_TRUE@Group: Libraries/Multimedia
@USE_ARTSC_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_ARTSC_TRUE@
@USE_ARTSC_TRUE@%description -n gstreamer-artsd
@USE_ARTSC_TRUE@Plugin for outputing to artsd sound server
@USE_ARTSC_TRUE@
@USE_ARTSC_TRUE@%files -n gstreamer-artsd
@USE_ARTSC_TRUE@%defattr(-, root, root)
@USE_ARTSC_TRUE@%{_libdir}/gst/libgstartsd*
@USE_ARTSC_TRUE@
@USE_ARTSC_TRUE@%post -n gstreamer-artsd
@USE_ARTSC_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_ALSA_TRUE@
@USE_ALSA_TRUE@%postun -n gstreamer-alsa
@USE_ALSA_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### ARTS WRAPPER ###
@USE_ARTS_TRUE@%package -n gstreamer-arts
@USE_ARTS_TRUE@Summary: GStreamer arts wrapper plugin
@USE_ARTS_TRUE@Group: Libraries/Multimedia
@USE_ARTS_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_ARTS_TRUE@Requires: kdelibs-sound >= 2
@USE_ARTS_TRUE@Summary: GStreamer arts wrapper plug-in.
@USE_ARTS_TRUE@Group: Libraries/Multimedia
@USE_ARTS_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_ARTS_TRUE@Requires: kdelibs-sound >= 2
@USE_ARTS_TRUE@BuildRequires: kdelibs-sound-devel >= 2
@USE_ARTS_TRUE@BuildRequires: gcc-c++
@USE_ARTS_TRUE@
@USE_ARTS_TRUE@%description -n gstreamer-arts
@USE_ARTS_TRUE@Plugin for wrapping arts plugins
@USE_ARTS_TRUE@This plug-in wraps arts plug-ins.
@USE_ARTS_TRUE@
@USE_ARTS_TRUE@%files -n gstreamer-arts
@USE_ARTS_TRUE@%defattr(-, root, root)
@USE_ARTS_TRUE@%{_libdir}/gst/libgstarts.*
@USE_ARTS_TRUE@%{_libdir}/gst/libgstarts.so
@USE_ARTS_TRUE@
@USE_ARTS_TRUE@%post -n gstreamer-arts
@USE_ARTS_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_ARTS_TRUE@
@USE_ARTS_TRUE@%postun -n gstreamer-arts
@USE_ARTS_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### ARTSD SOUND SERVER ###
@USE_ARTSC_TRUE@%package -n gstreamer-artsd
@USE_ARTSC_TRUE@Summary: GStreamer artsd output plug-in.
@USE_ARTSC_TRUE@Group: Libraries/Multimedia
@USE_ARTSC_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_ARTSC_TRUE@
@USE_ARTSC_TRUE@%description -n gstreamer-artsd
@USE_ARTSC_TRUE@Plug-in for outputting to artsd sound server.
@USE_ARTSC_TRUE@
@USE_ARTSC_TRUE@%files -n gstreamer-artsd
@USE_ARTSC_TRUE@%defattr(-, root, root)
@USE_ARTSC_TRUE@%{_libdir}/gst/libgstartsdsink.so
@USE_ARTSC_TRUE@
@USE_ARTSC_TRUE@%post -n gstreamer-artsd
@USE_ARTSC_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_ARTSC_TRUE@
@USE_ARTSC_TRUE@%postun -n gstreamer-artsd
@USE_ARTSC_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### AUDIOFILE ###
@USE_AUDIOFILE_TRUE@%package -n gstreamer-audiofile
@USE_AUDIOFILE_TRUE@Summary: GStreamer plugin audiofile support
@USE_AUDIOFILE_TRUE@Group: Libraries/Multimedia
@USE_AUDIOFILE_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_AUDIOFILE_TRUE@Requires: audiofile >= 0.2.1
@USE_AUDIOFILE_TRUE@Summary: GStreamer plug-in for audiofile support.
@USE_AUDIOFILE_TRUE@Group: Libraries/Multimedia
@USE_AUDIOFILE_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_AUDIOFILE_TRUE@Requires: audiofile >= 0.2.1
@USE_AUDIOFILE_TRUE@BuildRequires: audiofile-devel >= 0.2.1
@USE_AUDIOFILE_TRUE@
@USE_AUDIOFILE_TRUE@%description -n gstreamer-audiofile
@USE_AUDIOFILE_TRUE@Plugin for supporting reading and writing all files audiofile support
@USE_AUDIOFILE_TRUE@Plug-in for supporting reading and writing of all files supported by audiofile.
@USE_AUDIOFILE_TRUE@
@USE_AUDIOFILE_TRUE@%files -n gstreamer-audiofile
@USE_AUDIOFILE_TRUE@%defattr(-, root, root)
@USE_AUDIOFILE_TRUE@%{_libdir}/gst/libgstaudiofile*
@USE_AUDIOFILE_TRUE@%{_libdir}/gst/libgstaudiofile.so
@USE_AUDIOFILE_TRUE@
@USE_AUDIOFILE_TRUE@%post -n gstreamer-audiofile
@USE_AUDIOFILE_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_AUDIOFILE_TRUE@
@USE_AUDIOFILE_TRUE@%postun -n gstreamer-audiofile
@USE_AUDIOFILE_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### AVIFILE ###
@USE_AVIFILE_TRUE@%package -n gstreamer-avi
@USE_AVIFILE_TRUE@Summary: GStreamer plugin for AVI format movie playback
@USE_AVIFILE_TRUE@Group: Libraries/Multimedia
@USE_AVIFILE_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_AVIFILE_TRUE@Requires: avifile = 0.6.20011111DD
@USE_AVIFILE_TRUE@Requires: gstreamer-colorspace >= %{version}
@USE_AVIFILE_TRUE@Summary: GStreamer plug-in for AVI movie playback.
@USE_AVIFILE_TRUE@Group: Libraries/Multimedia
@USE_AVIFILE_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_AVIFILE_TRUE@Requires: gstreamer-colorspace >= %{version}
@USE_AVIFILE_TRUE@Requires: avifile = 0.6.20011111DD
@USE_AVIFILE_TRUE@BuildRequires: avifile-devel = 0.6.20011111DD
@USE_AVIFILE_TRUE@
@USE_AVIFILE_TRUE@%description -n gstreamer-avi
@USE_AVIFILE_TRUE@Plugins for playback of AVI format media files.
@USE_AVIFILE_TRUE@Plug-ins for playback of AVI format media files.
@USE_AVIFILE_TRUE@
@USE_AVIFILE_TRUE@%files -n gstreamer-avi
@USE_AVIFILE_TRUE@%defattr(-, root, root)
@USE_AVIFILE_TRUE@%{_libdir}/gst/libgstavidemux*
@USE_AVIFILE_TRUE@%{_libdir}/gst/libgstavimux*
@USE_AVIFILE_TRUE@%{_libdir}/gst/libgstwincodec*
@USE_AVIFILE_TRUE@%{_libdir}/gst/libgstavidemux.so
@USE_AVIFILE_TRUE@%{_libdir}/gst/libgstavimux.so
@USE_AVIFILE_TRUE@%{_libdir}/gst/libgstwincodec.so
@USE_AVIFILE_TRUE@
@USE_AVIFILE_TRUE@%post -n gstreamer-avi
@USE_AVIFILE_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_AVIFILE_TRUE@
@USE_AVIFILE_TRUE@%postun -n gstreamer-avi
@USE_AVIFILE_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### CDPARANOIA ###
@USE_CDPARANOIA_TRUE@%package -n gstreamer-cdparanoia
@USE_CDPARANOIA_TRUE@Summary: GStreamer plugin for CD audio input using CDParanoia IV
@USE_CDPARANOIA_TRUE@Group: Libraries/Multimedia
@USE_CDPARANOIA_TRUE@Requires: cdparanoia-libs >= alpha9.7
@USE_CDPARANOIA_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_CDPARANOIA_TRUE@Summary: GStreamer plug-in for CD audio input using CDParanoia IV.
@USE_CDPARANOIA_TRUE@Group: Libraries/Multimedia
@USE_CDPARANOIA_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_CDPARANOIA_TRUE@Requires: cdparanoia-libs >= alpha9.7
@USE_CDPARANOIA_TRUE@BuildRequires: cdparanoia-devel >= alpha9.7
@USE_CDPARANOIA_TRUE@
@USE_CDPARANOIA_TRUE@%description -n gstreamer-cdparanoia
@USE_CDPARANOIA_TRUE@Plugin for ripping audio tracks using cdparanoia under GStreamer
@USE_CDPARANOIA_TRUE@Plug-in for ripping audio tracks using cdparanoia under GStreamer.
@USE_CDPARANOIA_TRUE@
@USE_CDPARANOIA_TRUE@%files -n gstreamer-cdparanoia
@USE_CDPARANOIA_TRUE@%defattr(-, root, root)
@USE_CDPARANOIA_TRUE@%{_libdir}/gst/libgstcdparanoia*
@USE_CDPARANOIA_TRUE@%{_libdir}/gst/libgstcdparanoia.so
@USE_CDPARANOIA_TRUE@
@USE_CDPARANOIA_TRUE@%post -n gstreamer-cdparanoia
@USE_CDPARANOIA_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_CDPARANOIA_TRUE@
@USE_CDPARANOIA_TRUE@%postun -n gstreamer-cdparanoia
@USE_CDPARANOIA_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### DVDREAD ###
@USE_DVDREAD_TRUE@%package -n gstreamer-libdvd
@USE_DVDREAD_TRUE@Summary: GStreamer plugins for DVD playback
@USE_DVDREAD_TRUE@Group: Libraries/Multimedia
@USE_DVDREAD_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_DVDREAD_TRUE@Requires: libdvdread >= 0.9.0
@USE_DVDREAD_TRUE@%package -n gstreamer-libdvdread
@USE_DVDREAD_TRUE@Summary: GStreamer plug-in for DVD playback using libdvdread.
@USE_DVDREAD_TRUE@Group: Libraries/Multimedia
@USE_DVDREAD_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_DVDREAD_TRUE@Requires: libdvdread >= 0.9.0
@USE_DVDREAD_TRUE@BuildRequires: libdvdread-devel >= 0.9.0
@USE_DVDREAD_TRUE@Obsoletes: gstreamer-libdvd
@USE_DVDREAD_TRUE@
@USE_DVDREAD_TRUE@%description -n gstreamer-libdvd
@USE_DVDREAD_TRUE@Input and output plugin for the ALSA soundcard driver architecture.
@USE_DVDREAD_TRUE@%description -n gstreamer-libdvdread
@USE_DVDREAD_TRUE@Plug-in for reading DVDs using libdvdread under GStreamer.
@USE_DVDREAD_TRUE@
@USE_DVDREAD_TRUE@%files -n gstreamer-libdvd
@USE_DVDREAD_TRUE@%files -n gstreamer-libdvdread
@USE_DVDREAD_TRUE@%defattr(-, root, root)
@USE_DVDREAD_TRUE@%{_libdir}/gst/libgstdvd*
@USE_DVDREAD_TRUE@%{_libdir}/gst/libgstdvdreadsrc.so
@USE_DVDREAD_TRUE@
@USE_DVDREAD_TRUE@%post -n gstreamer-libdvdread
@USE_DVDREAD_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_DVDREAD_TRUE@
@USE_DVDREAD_TRUE@%post -n gstreamer-libdvd
@USE_DVDREAD_TRUE@%postun -n gstreamer-libdvdread
@USE_DVDREAD_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
## DXR3 ###
@USE_DXR3_TRUE@%package -n gstreamer-dxr3
@USE_DXR3_TRUE@Summary: GStreamer plug-in for playback using dxr3 card.
@USE_DXR3_TRUE@Group: Libraries/Multimedia
@USE_DXR3_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_DXR3_TRUE@Requires: em8300 => 0.12.0
@USE_DXR3_TRUE@BuildRequires: em8300-devel => 0.12.0
@USE_DXR3_TRUE@
@USE_DXR3_TRUE@%description -n gstreamer-dxr3
@USE_DXR3_TRUE@Plug-in supporting DVD playback using cards
@USE_DXR3_TRUE@with the dxr3 chipset like Hollywood Plus
@USE_DXR3_TRUE@and Creative Labs DVD cards.
@USE_DXR3_TRUE@
@USE_DXR3_TRUE@%files -n gstreamer-dxr3
@USE_DXR3_TRUE@%defattr(-, root, root)
@USE_DXR3_TRUE@%{_libdir}/gst/libgstdxr3.so
@USE_DXR3_TRUE@
@USE_DXR3_TRUE@%post -n gstreamer-dxr3
@USE_DXR3_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_DXR3_TRUE@
@USE_DXR3_TRUE@%postun -n gstreamer-dxr3
@USE_DXR3_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### ESD ###
@USE_ESD_TRUE@%package -n gstreamer-esd
@USE_ESD_TRUE@Summary: GStreamer plugin for ESD sound output
@USE_ESD_TRUE@Group: Libraries/Multimedia
@USE_ESD_TRUE@Requires: esound >= 0.2.8
@USE_ESD_TRUE@%package -n gstreamer-esound
@USE_ESD_TRUE@Summary: GStreamer plug-in for ESD sound output.
@USE_ESD_TRUE@Group: Libraries/Multimedia
@USE_ESD_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_ESD_TRUE@Requires: esound >= 0.2.8
@USE_ESD_TRUE@BuildRequires: esound-devel >= 0.2.8
@USE_ESD_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_ESD_TRUE@Obsoletes: gstreamer-esd
@USE_ESD_TRUE@
@USE_ESD_TRUE@%description -n gstreamer-esd
@USE_ESD_TRUE@Output and monitoring plugins for GStreamer for use with the esound package
@USE_ESD_TRUE@%description -n gstreamer-esound
@USE_ESD_TRUE@Output and monitoring plug-ins for GStreamer using ESound.
@USE_ESD_TRUE@
@USE_ESD_TRUE@%files -n gstreamer-esd
@USE_ESD_TRUE@%files -n gstreamer-esound
@USE_ESD_TRUE@%defattr(-, root, root)
@USE_ESD_TRUE@%{_libdir}/gst/libgstesdmon*
@USE_ESD_TRUE@%{_libdir}/gst/libgstesdsink*
@USE_ESD_TRUE@%{_libdir}/gst/libgstesdmon.so
@USE_ESD_TRUE@%{_libdir}/gst/libgstesdsink.so
@USE_ESD_TRUE@
@USE_ESD_TRUE@%post -n gstreamer-esd
@USE_ESD_TRUE@%post -n gstreamer-esound
@USE_ESD_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_ESD_TRUE@
@USE_ESD_TRUE@%postun -n gstreamer-esd
@USE_ESD_TRUE@%postun -n gstreamer-esound
@USE_ESD_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_ESD_TRUE@/sbin/ldconfig
### FESTIVAL ###
%package -n gstreamer-festival
Summary: GStreamer plugin for text-to-speech support using Festival
Group: Libraries/Multimedia
Requires: gstreamer-plugins >= %{version}
%description -n gstreamer-festival
Element for text-to-speech using the festival server.
%files -n gstreamer-festival
%defattr(-, root, root)
%{_libdir}/gst/libgstfestival*
%post -n gstreamer-festival
%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### FLAC ###
@USE_FLAC_TRUE@%package -n gstreamer-flac
@USE_FLAC_TRUE@Summary: GStreamer plugin for FLAC lossless audio format
@USE_FLAC_TRUE@Group: Libraries/Multimedia
@USE_FLAC_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_FLAC_TRUE@Requires: flac >= 1.0.0
@USE_FLAC_TRUE@Summary: GStreamer plug-in for FLAC lossless audio.
@USE_FLAC_TRUE@Group: Libraries/Multimedia
@USE_FLAC_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_FLAC_TRUE@Requires: flac >= 1.0.0
@USE_FLAC_TRUE@BuildRequires: flac-devel >= 1.0.0
@USE_FLAC_TRUE@
@USE_FLAC_TRUE@%description -n gstreamer-flac
@USE_FLAC_TRUE@Plugin for the free FLAC lossless audio format.
@USE_FLAC_TRUE@Plug-in for the free FLAC lossless audio format.
@USE_FLAC_TRUE@
@USE_FLAC_TRUE@%files -n gstreamer-flac
@USE_FLAC_TRUE@%defattr(-, root, root)
@USE_FLAC_TRUE@%{_libdir}/gst/libgstflac*
@USE_FLAC_TRUE@%{_libdir}/gst/libgstflac.so
@USE_FLAC_TRUE@
@USE_FLAC_TRUE@%post -n gstreamer-flac
@USE_FLAC_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_FLAC_TRUE@
@USE_FLAC_TRUE@%postun -n gstreamer-flac
@USE_FLAC_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### GNOME VFS ###
### GNOME VFS 2 ###
@USE_GNOME_VFS_TRUE@%package -n gstreamer-gnomevfs
@USE_GNOME_VFS_TRUE@Summary: GStreamer plugins for GNOME VFS input and output
@USE_GNOME_VFS_TRUE@Group: Libraries/Multimedia
@USE_GNOME_VFS_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_GNOME_VFS_TRUE@Requires: gnome-vfs2 > 1.9.4.00
@USE_GNOME_VFS_TRUE@Summary: GStreamer plug-ins for Gnome-VFS input and output.
@USE_GNOME_VFS_TRUE@Group: Libraries/Multimedia
@USE_GNOME_VFS_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_GNOME_VFS_TRUE@Requires: gnome-vfs2 > 1.9.4.00
@USE_GNOME_VFS_TRUE@BuildRequires: gnome-vfs2-devel > 1.9.4.00
@USE_GNOME_VFS_TRUE@
@USE_GNOME_VFS_TRUE@%description -n gstreamer-gnomevfs
@USE_GNOME_VFS_TRUE@Plugins for reading and writing through GNOME VFS.
@USE_GNOME_VFS_TRUE@Plug-ins for reading and writing through GNOME VFS.
@USE_GNOME_VFS_TRUE@
@USE_GNOME_VFS_TRUE@%files -n gstreamer-gnomevfs
@USE_GNOME_VFS_TRUE@%defattr(-, root, root)
@USE_GNOME_VFS_TRUE@%{_libdir}/gst/libgstgnomevfs*
@USE_GNOME_VFS_TRUE@%{_libdir}/gst/libgstgnomevfssrc.so
@USE_GNOME_VFS_TRUE@%{_libdir}/gst/libgstgnomevfssink.so
@USE_GNOME_VFS_TRUE@
@USE_GNOME_VFS_TRUE@%post -n gstreamer-gnomevfs
@USE_GNOME_VFS_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_GNOME_VFS_TRUE@
@USE_GNOME_VFS_TRUE@%postun -n gstreamer-gnomevfs
@USE_GNOME_VFS_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### GSM ###
@USE_GSM_TRUE@%package -n gstreamer-gsm
@USE_GSM_TRUE@Summary: GStreamer plugin for GSM lossy audio format
@USE_GSM_TRUE@Group: Libraries/Multimedia
@USE_GSM_TRUE@Requires: gsm >= 1.0.10
@USE_GSM_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_GSM_TRUE@Summary: GStreamer plug-in for GSM lossy audio format.
@USE_GSM_TRUE@Group: Libraries/Multimedia
@USE_GSM_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_GSM_TRUE@Requires: gsm >= 1.0.10
@USE_GSM_TRUE@BuildRequires: gsm-devel >= 1.0.10
@USE_GSM_TRUE@
@USE_GSM_TRUE@%description -n gstreamer-gsm
@USE_GSM_TRUE@Output plugin for GStreamer to convert to GSM lossy audio format.
@USE_GSM_TRUE@Output plug-in for GStreamer to convert to GSM lossy audio format.
@USE_GSM_TRUE@
@USE_GSM_TRUE@%files -n gstreamer-gsm
@USE_GSM_TRUE@%defattr(-, root, root)
@USE_GSM_TRUE@%{_libdir}/gst/libgstgsm*
@USE_GSM_TRUE@%{_libdir}/gst/libgstgsm.so
@USE_GSM_TRUE@
@USE_GSM_TRUE@%post -n gstreamer-gsm
@USE_GSM_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_GSM_TRUE@
@USE_GSM_TRUE@%postun -n gstreamer-gsm
@USE_GSM_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### HERMES ###
@USE_HERMES_TRUE@%package -n gstreamer-colorspace
@USE_HERMES_TRUE@Summary: GStreamer colorspace conversion plugin
@USE_HERMES_TRUE@Group: Libraries/Multimedia
@USE_HERMES_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_HERMES_TRUE@Requires: Hermes => 1.3.0
@USE_HERMES_TRUE@Summary: GStreamer colorspace conversion plug-in.
@USE_HERMES_TRUE@Group: Libraries/Multimedia
@USE_HERMES_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_HERMES_TRUE@Requires: Hermes => 1.3.0
@USE_HERMES_TRUE@BuildRequires: Hermes-devel => 1.3.0
@USE_HERMES_TRUE@%description -n gstreamer-colorspace
@USE_HERMES_TRUE@Colorspace plugin based on Hermes library
@USE_HERMES_TRUE@Colorspace plug-in based on Hermes library.
@USE_HERMES_TRUE@
@USE_HERMES_TRUE@%files -n gstreamer-colorspace
@USE_HERMES_TRUE@%defattr(-, root, root)
@USE_HERMES_TRUE@%{_libdir}/gst/libgstcolorspace*
@USE_HERMES_TRUE@%{_libdir}/gst/libgstcolorspace.so
@USE_HERMES_TRUE@
@USE_HERMES_TRUE@%post -n gstreamer-colorspace
@USE_HERMES_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_HERMES_TRUE@
@USE_HERMES_TRUE@%postun -n gstreamer-colorspace
@USE_HERMES_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### HTTP ###
@USE_HTTP_TRUE@%package -n gstreamer-httpsrc
@USE_HTTP_TRUE@Summary: GStreamer plug-in for http using libghttp.
@USE_HTTP_TRUE@Group: Libraries/Multimedia
@USE_HTTP_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_HTTP_TRUE@Requires: libghttp => 1.0.9
@USE_HTTP_TRUE@BuildRequires: libghttp-devel => 1.0.9
@USE_HTTP_TRUE@
@USE_HTTP_TRUE@%description -n gstreamer-httpsrc
@USE_HTTP_TRUE@Plug-in supporting the http protocol based
@USE_HTTP_TRUE@on the libghttp library.
@USE_HTTP_TRUE@
@USE_HTTP_TRUE@%files -n gstreamer-httpsrc
@USE_HTTP_TRUE@%defattr(-, root, root)
@USE_HTTP_TRUE@%{_libdir}/gst/libgsthttpsrc.so
@USE_HTTP_TRUE@
@USE_HTTP_TRUE@%post -n gstreamer-httpsrc
@USE_HTTP_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_HTTP_TRUE@
@USE_HTTP_TRUE@%postun -n gstreamer-httpsrc
@USE_HTTP_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
#### JACK AUDIO CONNECTION KIT ###
@USE_JACK_TRUE@%package -n gstreamer-jack
@USE_JACK_TRUE@Summary: GStreamer plug-in for the Jack Sound Server.
@USE_JACK_TRUE@Group: Libraries/Multimedia
@USE_JACK_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_JACK_TRUE@Requires: jack-audio-connection-kit => 0.28.0
@USE_JACK_TRUE@
@USE_JACK_TRUE@%description -n gstreamer-jack
@USE_JACK_TRUE@Plug-in for the JACK professional sound server.
@USE_JACK_TRUE@
@USE_JACK_TRUE@%files -n gstreamer-jack
@USE_JACK_TRUE@%defattr(-, root, root)
@USE_JACK_TRUE@%{_libdir}/gst/libgstjack.so
@USE_JACK_TRUE@
@USE_JACK_TRUE@%post -n gstreamer-jack
@USE_JACK_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_JACK_TRUE@
@USE_JACK_TRUE@%postun -n gstreamer-jack
@USE_JACK_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### JPEG ###
@USE_JPEG_TRUE@%package -n gstreamer-jpeg
@USE_JPEG_TRUE@Summary: GStreamer plugin for jpeg images
@USE_JPEG_TRUE@Group: Libraries/Multimedia
@USE_JPEG_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_JPEG_TRUE@Requires: libjpeg
@USE_JPEG_TRUE@Summary: GStreamer plug-in for JPEG images.
@USE_JPEG_TRUE@Group: Libraries/Multimedia
@USE_JPEG_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_JPEG_TRUE@Requires: libjpeg
@USE_JPEG_TRUE@BuildRequires: libjpeg-devel
@USE_JPEG_TRUE@
@USE_JPEG_TRUE@%description -n gstreamer-jpeg
@USE_JPEG_TRUE@Output plugin for GStreamer using libjpeg
@USE_JPEG_TRUE@Output plug-in for GStreamer using libjpeg.
@USE_JPEG_TRUE@
@USE_JPEG_TRUE@%files -n gstreamer-jpeg
@USE_JPEG_TRUE@%defattr(-, root, root)
@USE_JPEG_TRUE@%{_libdir}/gst/libgstjpeg*
@USE_JPEG_TRUE@%{_libdir}/gst/libgstjpeg.so
@USE_JPEG_TRUE@
@USE_JPEG_TRUE@%post -n gstreamer-jpeg
@USE_JPEG_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_JPEG_TRUE@
@USE_JPEG_TRUE@%postun -n gstreamer-jpeg
@USE_JPEG_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### LADSPA ###
@USE_LADSPA_TRUE@%package -n gstreamer-ladspa
@USE_LADSPA_TRUE@Summary: GStreamer wrapper for LADSPA plugins
@USE_LADSPA_TRUE@Group: Libraries/Multimedia
@USE_LADSPA_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_LADSPA_TRUE@Summary: GStreamer wrapper for LADSPA plug-ins.
@USE_LADSPA_TRUE@Group: Libraries/Multimedia
@USE_LADSPA_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_LADSPA_TRUE@Requires: ladspa
@USE_LADSPA_TRUE@BuildRequires: ladspa-devel
@USE_LADSPA_TRUE@
@USE_LADSPA_TRUE@%description -n gstreamer-ladspa
@USE_LADSPA_TRUE@Plug-in which wraps LADSPA plug-ins for use by GStreamer applications.
@USE_LADSPA_TRUE@We suggest you also get the cmt package of ladspa plug-ins
@USE_LADSPA_TRUE@and steve harris's swh-plugins package.
@USE_LADSPA_TRUE@
@USE_LADSPA_TRUE@%files -n gstreamer-ladspa
@USE_LADSPA_TRUE@%defattr(-, root, root)
@USE_LADSPA_TRUE@%{_libdir}/gst/libgstladspa*
@USE_LADSPA_TRUE@
@USE_LADSPA_TRUE@%description -n gstreamer-ladspa
@USE_LADSPA_TRUE@Plugin which wraps LADSPA plugins for use by GStreamer applications.
@USE_LADSPA_TRUE@%{_libdir}/gst/libgstladspa.so
@USE_LADSPA_TRUE@
@USE_LADSPA_TRUE@%post -n gstreamer-ladspa
@USE_LADSPA_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_LADSPA_TRUE@
@USE_LADSPA_TRUE@%postun -n gstreamer-ladspa
@USE_LADSPA_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
### LAME ###
@USE_LAME_TRUE@%package -n gstreamer-lame
@USE_LAME_TRUE@Summary: GStreamer plugin encoding mp3 songs
@USE_LAME_TRUE@Group: Libraries/Multimedia
@USE_LAME_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_LAME_TRUE@Requires: lame >= 3.89
@USE_LAME_TRUE@Summary: GStreamer plug-in encoding mp3 songs using lame.
@USE_LAME_TRUE@Group: Libraries/Multimedia
@USE_LAME_TRUE@Requires: gstreamer-plugins >= %{version}
@USE_LAME_TRUE@Requires: lame >= 3.89
@USE_LAME_TRUE@BuildRequires: lame-devel >= 3.89
@USE_LAME_TRUE@
@USE_LAME_TRUE@%description -n gstreamer-lame
@USE_LAME_TRUE@Plugin for encoding mp3 with lame
@USE_LAME_TRUE@Plug-in for encoding mp3 with lame under GStreamer.
@USE_LAME_TRUE@
@USE_LAME_TRUE@%files -n gstreamer-lame
@USE_LAME_TRUE@%defattr(-, root, root)
@USE_LAME_TRUE@%{_libdir}/gst/libgstlame*
@USE_LAME_TRUE@%{_libdir}/gst/libgstlame.so
@USE_LAME_TRUE@
@USE_LAME_TRUE@%post -n gstreamer-lame
@USE_LAME_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null
@USE_LAME_TRUE@
@USE_LAME_TRUE@%postun -n gstreamer-lame
@USE_LAME_TRUE@%{_bindir}/gst-register --gst-mask=0 2> /dev/null