vpx: Fix build against libvpx 1.8

The deprecated debug visualizer was removed.
parent f5f1de54
Pipeline #17764 passed with stages
in 22 minutes and 1 second
......@@ -1054,6 +1054,10 @@ AG_GST_CHECK_FEATURE(VPX, [VPX decoder], vpx, [
AC_DEFINE(HAVE_VPX_1_4, 1, [Defined if the VPX library version is 1.4 or bigger])
], [true])
PKG_CHECK_MODULES(VPX_180, vpx >= 1.8.0, [
AC_DEFINE(HAVE_VPX_1_8, 1, [Defined if the VPX library version is 1.8 or bigger])
], [true])
LIBS="$OLD_LIBS"
CFLAGS="$OLD_CFLAGS"
fi
......
......@@ -62,6 +62,7 @@ gst_vpx_dec_post_processing_flags_get_type (void)
{C_FLAGS (VP8_DEBLOCK), "Deblock", "deblock"},
{C_FLAGS (VP8_DEMACROBLOCK), "Demacroblock", "demacroblock"},
{C_FLAGS (VP8_ADDNOISE), "Add noise", "addnoise"},
#ifndef HAVE_VPX_1_8
{C_FLAGS (VP8_DEBUG_TXT_FRAME_INFO),
"Print frame information",
"visualize-frame-info"},
......@@ -74,6 +75,7 @@ gst_vpx_dec_post_processing_flags_get_type (void)
{C_FLAGS (VP8_DEBUG_TXT_RATE_INFO),
"Print video rate info",
"visualize-rate-info"},
#endif
{C_FLAGS (VP8_MFQE), "Multi-frame quality enhancement", "mfqe"},
{0, NULL, NULL}
};
......
......@@ -48,6 +48,10 @@ if vpx_dep.found()
vpx_args += '-DHAVE_VPX_1_4'
endif
if dependency('vpx', version : '>=1.8.0', required : false).found()
vpx_args += '-DHAVE_VPX_1_8'
endif
gstvpx = library('gstvpx',
vpx_sources,
c_args : gst_plugins_good_args + vpx_args,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment