• Harish Krupo's avatar
    meson.build: Fix warning for configure_file · b81fc517
    Harish Krupo authored
    We claim to support meson versions >= 0.47 but the `install:` argument
    in configure_file was introduced in version 0.50. This produces the
    following meson warning:
    
    WARNING: Project specifies a minimum meson_version '>= 0.47' but uses
    features which were added in newer versions:
     * 0.50.0: {'install arg in configure_file'}
    
    From the documentation for the install argument [1]:
    " When omitted it (install) defaults to true when install_dir is set and
    not empty, false otherwise."
    
    So, remove the `install:` argument and just depend on `install_dir` for
    installing.
    
    Fixes: #225
    
    [1] https://mesonbuild.com/Reference-manual.html#configure_fileSigned-off-by: Harish Krupo's avatarHarish Krupo <harish.krupo.kps@intel.com>
    b81fc517
Name
Last commit
Last update
..
meson.build Loading commit data...
weston-debug.man Loading commit data...
weston-drm.man Loading commit data...
weston-rdp.man Loading commit data...
weston.ini.man Loading commit data...
weston.man Loading commit data...