Commit 83b03775 authored by Tim-Philipp Müller's avatar Tim-Philipp Müller 🐠
Browse files

download: update for 1.20.3 binaries

parent 8f3fef22
......@@ -16,19 +16,19 @@ split into runtime and development packages. For development, you will want to
install both packages.
* MSVC 64-bit (VS 2019, Release CRT)
- [1.20.2 runtime installer](/data/pkg/windows/1.20.2/msvc/gstreamer-1.0-msvc-x86_64-1.20.2.msi)
- [1.20.2 development installer](/data/pkg/windows/1.20.2/msvc/gstreamer-1.0-devel-msvc-x86_64-1.20.2.msi)
- [1.20.3 runtime installer](/data/pkg/windows/1.20.3/msvc/gstreamer-1.0-msvc-x86_64-1.20.3.msi)
- [1.20.3 development installer](/data/pkg/windows/1.20.3/msvc/gstreamer-1.0-devel-msvc-x86_64-1.20.3.msi)
* MSVC 32-bit (VS 2019, Release CRT)
- [1.20.2 runtime installer](/data/pkg/windows/1.20.2/msvc/gstreamer-1.0-msvc-x86-1.20.2.msi)
- [1.20.2 development installer](/data/pkg/windows/1.20.2/msvc/gstreamer-1.0-devel-msvc-x86-1.20.2.msi)
- [1.20.3 runtime installer](/data/pkg/windows/1.20.3/msvc/gstreamer-1.0-msvc-x86-1.20.3.msi)
- [1.20.3 development installer](/data/pkg/windows/1.20.3/msvc/gstreamer-1.0-devel-msvc-x86-1.20.3.msi)
* MinGW 64-bit
- [1.20.2 runtime installer](/data/pkg/windows/1.20.2/mingw/gstreamer-1.0-mingw-x86_64-1.20.2.msi)
- [1.20.2 development installer](/data/pkg/windows/1.20.2/mingw/gstreamer-1.0-devel-mingw-x86_64-1.20.2.msi)
- [1.20.3 runtime installer](/data/pkg/windows/1.20.3/mingw/gstreamer-1.0-mingw-x86_64-1.20.3.msi)
- [1.20.3 development installer](/data/pkg/windows/1.20.3/mingw/gstreamer-1.0-devel-mingw-x86_64-1.20.3.msi)
* MinGW 32-bit
- [1.20.2 runtime installer](/data/pkg/windows/1.20.2/mingw/gstreamer-1.0-mingw-x86-1.20.2.msi)
- [1.20.2 development installer](/data/pkg/windows/1.20.2/mingw/gstreamer-1.0-devel-mingw-x86-1.20.2.msi)
- [1.20.3 runtime installer](/data/pkg/windows/1.20.3/mingw/gstreamer-1.0-mingw-x86-1.20.3.msi)
- [1.20.3 development installer](/data/pkg/windows/1.20.3/mingw/gstreamer-1.0-devel-mingw-x86-1.20.3.msi)
For each of the above listed targets, [a zip file with `.msm` modules](/data/pkg/windows/1.20.2/)
For each of the above listed targets, [a zip file with `.msm` modules](/data/pkg/windows/1.20.3/)
is available for integration into your own WiX-based app installer.
If you are not sure which to pick between MSVC and MinGW, just pick MSVC.
......@@ -54,9 +54,9 @@ Binary releases built to target the Universal Windows Platform (UWP). Used for
shipping apps on the Windows Store, such as for an XBox, HoloLens 2, etc.
* UWP Universal (ARM64, X86, X86_64) (VS 2019, Release CRT)
- [1.20.2 runtime + development tarball](/data/pkg/windows/1.20.2/uwp/gstreamer-1.0-uwp-universal-1.20.2.tar.xz)
- [1.20.3 runtime + development tarball](/data/pkg/windows/1.20.3/uwp/gstreamer-1.0-uwp-universal-1.20.3.tar.xz)
* UWP Universal (ARM64, X86, X86_64) (VS 2019, Debug CRT)
- [1.20.2 runtime + development tarball](/data/pkg/windows/1.20.2/uwp/gstreamer-1.0-uwp+debug-universal-1.20.2.tar.xz)
- [1.20.3 runtime + development tarball](/data/pkg/windows/1.20.3/uwp/gstreamer-1.0-uwp+debug-universal-1.20.3.tar.xz)
UWP apps cannot use plugins that use dependencies built with MinGW because of
forbidden APIs. Hence, these plugins are omitted from the binaries.
......@@ -174,8 +174,8 @@ you will want to install _both_ packages. The target SDK version for 1.18 and
1.20 is macOS 10.11.
* **macOS Universal (X86_64 & ARM64) 1.20 release (current stable version)**
- **[1.20.2 runtime installer](/data/pkg/osx/1.20.2/gstreamer-1.0-1.20.2-universal.pkg)**
- **[1.20.2 development installer](/data/pkg/osx/1.20.2/gstreamer-1.0-devel-1.20.2-universal.pkg)**
- **[1.20.3 runtime installer](/data/pkg/osx/1.20.3/gstreamer-1.0-1.20.3-universal.pkg)**
- **[1.20.3 development installer](/data/pkg/osx/1.20.3/gstreamer-1.0-devel-1.20.3-universal.pkg)**
* macOS X86_64 1.18 release (old stable version)
- [1.18.6 runtime installer](/data/pkg/osx/1.18.6/gstreamer-1.0-1.18.6-x86_64.pkg)
- [1.18.6 development installer](/data/pkg/osx/1.18.6/gstreamer-1.0-devel-1.18.6-x86_64.pkg)
......@@ -193,7 +193,7 @@ the same system.
Binary releases are available with each in the form of a single "universal"
tarball with `armv7`, `arm64`, `x86`, and `x86_64` architectures in subfolders.
* **Android Universal [1.20.2 tarball](/data/pkg/android/1.20.2/gstreamer-1.0-android-universal-1.20.2.tar.xz) (current stable version)**
* **Android Universal [1.20.3 tarball](/data/pkg/android/1.20.3/gstreamer-1.0-android-universal-1.20.3.tar.xz) (current stable version)**
* Android Universal [1.18.6 tarball](/data/pkg/android/1.18.6/gstreamer-1.0-android-universal-1.18.6.tar.xz) (old stable version)
The Android NDKs used by the stable releases are:
......@@ -252,7 +252,7 @@ Binary releases that integrate into XCode are available in the form of a single
and the target SDK version for 1.16.x was iOS 9.0, and for both 1.18.x and
1.20.x is iOS 11.0.
* **iOS Universal [1.20.2 framework](/data/pkg/ios/1.20.2/gstreamer-1.0-devel-1.20.2-ios-universal.pkg) (ARM64, X86_64) (current stable version)**
* **iOS Universal [1.20.3 framework](/data/pkg/ios/1.20.3/gstreamer-1.0-devel-1.20.3-ios-universal.pkg) (ARM64, X86_64) (current stable version)**
* iOS Universal [1.18.6 framework](/data/pkg/ios/1.18.6/gstreamer-1.0-devel-1.18.6-ios-universal.pkg) (ARM64, X86_64) (old stable version)
[Older 1.x binary releases](/data/pkg/ios) are also available.
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment