Skip to content

pluginloader-win32: Early terminate if plugin loader binary is not installed

External plugin loader support for Windows is introduced in this dev cycle. Since helper binary was not required (useless) before this version, people may not ship the binary with new GStreamer version, then they will observe warning message.

Instead of displaying the warning at plugin loading time, checks helper bin earlier and disable external plugin loader if helper binary is not installed.

Fixes: cerbero#448 (closed)

Merge request reports