Makefile.am: remove some files

Original commit message from CVS:

* Makefile.am:
remove some files
* README:
reinstate and update
* DEVEL:
* REQUIREMENTS:
removed
* LICENSE:
* docs/random/LICENSE:
moved to random
parent 6fe3affa
2005-11-30 Thomas Vander Stichele <thomas at apestaart dot org>
* Makefile.am:
remove some files
* README:
reinstate and update
* DEVEL:
* REQUIREMENTS:
removed
* LICENSE:
* docs/random/LICENSE:
moved to random
2005-11-30 Edward Hervey <edward@fluendo.com>
* gst/gsttypefind.c: (gst_type_find_register):
......
Development Notes and Random Wisdom
* in libs like dparams, include the respective dparam headers with
#include "dparams.h"
instead of
#include <gst/libs/control/dparams.h>
because the latter will, if the include flags are set that way, first look
for the installed headers instead of the newest one, which is in your source
dir.
* When doing releases, please follow the guidelines in docs
......@@ -58,7 +58,7 @@ debug:
EXTRA_DIST = \
gstreamer.spec gstreamer.spec.in gst-element-check.m4 \
configure.ac autogen.sh depcomp \
REQUIREMENTS ABOUT-NLS DOCBUILDING DEVEL RELEASE \
ABOUT-NLS RELEASE \
$(win32)
CLEANFILES = gst-element-check-@GST_MAJORMINOR@.m4
......
......@@ -7,6 +7,24 @@ This package is in the 0.9.x series. This means that this is a
development series leading up to a stable 0.10.x series.
You have been warned.
WHERE TO START
--------------
We have a website at
http://gstreamer.freedesktop.org/
You should start by going through our FAQ at
http://gstreamer.freedesktop.org/data/doc/gstreamer/head/faq/html/
There is more documentation; go to
http://gstreamer.freedesktop.org/documentation
You can subscribe to our mailing lists; see the website for details.
We track bugs in GNOME's bugzilla; see the website for details.
You can join us on IRC - #gstreamer on irc.freenode.org
GStreamer 0.9 development series - Hung by a Thread
---------------------------------------------------
......@@ -117,6 +135,18 @@ set of available plug-ins into four modules:
problem and send us a patch, or bribe someone into fixing them for you.
- New contributors can start here for things to work on.
PLATFORMS
---------
- Linux is of course fully supported
- FreeBSD is reported to work; other BSD's should work too
- Solaris is reported to work; a specific sunaudiosink plugin have been written
- MacOSX is reported to work; specific audio and video sinks have been written
- Windows support is experimental but improving. Output sinks have been
written but are not yet included in the code. We support
- MSys/MingW builds
- Microsoft Visual Studio 6 builds (see win32/)
INSTALLING FROM PACKAGES
------------------------
......@@ -206,9 +236,11 @@ PLUG-IN DEPENDENCIES AND LICENSES
GStreamer is developed under the terms of the LGPL (see LICENSE file for
details). Some of our plug-ins however rely on libraries which are available
under other licenses. This means that if you are using an application which
has a non-GPL compatible license (for instance a closed-source application)
with GStreamer, you have to make sure not to use GPL-linked plug-ins.
under other licenses. This means that if you are distributing an application
which has a non-GPL compatible license (for instance a closed-source
application) with GStreamer, you have to make sure not to distribute GPL-linked
plug-ins.
When using GPL-linked plug-ins, GStreamer is for all practical reasons
under the GPL itself.
......
GStreamer uses a *large* array of tools and libraries, most of which are
optional. We have attempted to make sure that any code that depends on
optional libraries doesn't get built unless you have those libraries. If
you find this not to be the case, please, let us know by filing a bug
report at http://sourceforge.net/bugs/?group_id=1936.
Required libraries:
===================
glib2
libxml2 (also called gnome-xml, available from http://xmlsoft.org/)
These libraries are all central parts of gnome, and are available from the
ftp.gnome.org or its mirrors, amongst other places.
Optional libraries for Plugins:
==============================
The vast number of optional libraries that can be used for plugins are
listed in the REQUIREMENTS document in the gst-plugins package.
Required tools:
===============
bison >= 1.35
flex
An extra set of tools is required if you wish to build GStreamer out of
CVS (using autogen.sh):
autoconf 2.52
automake 1.6
libtool v1.4 or better
pkgconfig 0.9.0 (http://www.freedesktop.org/software/pkgconfig/)
Optional tools:
===============
gtkdoc
db2html
fig2dev
xsltproc
To build pdf and ps version of docs
===================================
passivetex
xmltex
tetex-dvips
Optional debian packages:
=========================
(This is an incomplete list, made only of problems which have been reported,
rather than by an audit.)
task-helix-gnome-dev OR libgnome-dev
gtk-doc-tools 0.4-0.2 -- needed to build documentation
Alternatively, the docbook-gnome-bin package, which is available by adding the
following lines to apt's sources.list (/etc/apt/sources.list):
deb ftp://ftp.home-of-linux.org/pub/debian gnome/
deb-src ftp://ftp.home-of-linux.org/pub/debian gnome/
......@@ -27,6 +27,9 @@ network connections also need a protocol to do this.
#GstBuffer, #GstCaps, #GstEvent
</para>
<!-- ##### SECTION Stability_Level ##### -->
<!-- ##### ENUM GstDPHeaderFlag ##### -->
<para>
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment