Commit c89e9afc authored by gb's avatar gb

Initial import of the gstreamer-vaapi hierarchy.

parents
Gwenole Beauchesne <gbeauchesne@splitted-desktop.com> - Primary author
This diff is collapsed.
AUTOMAKE_OPTIONS = foreign
SUBDIRS = gst-libs sys
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = \
aclocal.m4 compile config.guess config.sub \
configure depcomp install-sh ltmain.sh \
Makefile.in missing config.h.in
gst-vaapi NEWS -- summary of changes. 2010-01-DD
Copyright (C) 2010 Splitted-Desktop Systems
Version 0.1.0 - DD.Jan.2010
* Initial release
gst-vaapi
VA API support to GStreamer
Copyright (C) 2010 Splitted-Desktop Systems
License
-------
gst-vaapi is available under the terms of the GNU General Public
License.
Overview
--------
gst-vaapi consists in a VA API based videosink for GStreamer and
helper libraries.
Requirements
------------
gstreamer-0.10 >= 0.10.0
gstreamer-plugins-base-0.10 >= 0.10.0
#! /bin/sh
autoreconf -v --install
./configure "$@"
# gst version number
m4_define([gst_major_version], [0])
m4_define([gst_minor_version], [10])
m4_define([gst_micro_version], [0])
m4_define([gst_major_minor_version],
[gst_major_version.gst_minor_version])
m4_define([gst_version],
[gst_major_version.gst_minor_version.gst_micro_version])
# gst plugins-base version number
m4_define([gst_plugins_base_major_version], [0])
m4_define([gst_plugins_base_minor_version], [10])
m4_define([gst_plugins_base_micro_version], [0])
m4_define([gst_plugins_base_version],
[gst_plugins_base_major_version.gst_plugins_base_minor_version.gst_plugins_base_micro_version])
# gst_vaapi package version number
m4_define([gst_vaapi_major_version], [0])
m4_define([gst_vaapi_minor_version], [1])
m4_define([gst_vaapi_micro_version], [0])
m4_define([gst_vaapi_version],
[gst_vaapi_major_version.gst_vaapi_minor_version.gst_vaapi_micro_version])
AC_PREREQ([2.57])
AC_INIT([gst_vaapi], [gst_vaapi_version],
[gbeauchesne@splitted-desktop.com],
[gstreamer-vaapi])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE
AM_CONFIG_HEADER([config.h])
dnl Versions for GStreamer and plugins-base
GST_MAJORMINOR=gst_major_minor_version
GST_VERSION_REQUIRED=gst_version
GST_PLUGINS_BASE_VERSION_REQUIRED=gst_plugins_base_version
AC_SUBST(GST_MAJORMINOR)
dnl Check for tools
AC_PROG_CC
AC_PROG_LIBTOOL
dnl Check for GStreamer
PKG_CHECK_MODULES([GST],
[gstreamer-$GST_MAJORMINOR >= $GST_VERSION_REQUIRED]
)
AC_SUBST(GST_CFLAGS)
AC_SUBST(GST_LIBS)
dnl Check for GStreamer plugins-base
PKG_CHECK_MODULES([GST_PLUGINS_BASE],
[gstreamer-plugins-base-$GST_MAJORMINOR >= $GST_PLUGINS_BASE_VERSION_REQUIRED]
)
AC_SUBST(GST_PLUGINS_BASE_CFLAGS)
AC_SUBST(GST_PLUGINS_BASE_LIBS)
dnl Check for the GStreamer plugins directory
AC_MSG_CHECKING([for GStreamer plugins directory])
GST_PLUGINS_DIR=`$PKG_CONFIG gstreamer-$GST_MAJORMINOR --variable pluginsdir`
if test -z "$GST_PLUGINS_DIR"; then
echo "FAIL FAIL FAIL"
GST_PLUGINS_DIR="\$(libdir)/gstreamer-$GST_MAJORMINOR"
fi
AC_MSG_RESULT([$GST_PLUGINS_DIR])
plugindir="$GST_PLUGINS_DIR"
AC_SUBST(plugindir)
dnl Check for VA API
PKG_CHECK_MODULES(LIBVA_DEPS, [libva])
PKG_CHECK_MODULES(LIBVA_X11_DEPS, [libva-x11])
dnl Check for SDS extensions to VA API
AC_CACHE_CHECK([for VA API],
ac_cv_libva_sds_extensions, [
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $LIBVA_DEPS_CFLAGS"
AC_TRY_COMPILE([
#include <va/va_version.h>
#if VA_MAJOR_VERSION == 0 && VA_MINOR_VERSION == 29
# if !defined(VA_SDS_VERSION) || (VA_SDS_VERSION < $LIBVA_SDS_VERSION_0_29)
# error "VA API version >= 0.29.0-sds$LIBVA_SDS_VERSION_0_29 is required"
# endif
#elif VA_MAJOR_VERSION == 0 && VA_MINOR_VERSION == 30
# if !defined(VA_SDS_VERSION) || (VA_SDS_VERSION < $LIBVA_SDS_VERSION_0_30)
# error "VA API version >= 0.30.0-sds$LIBVA_SDS_VERSION_0_30 is required"
# endif
#elif !VA_CHECK_VERSION(0,31,0)
# error "VA API version >= 0.31 is required"
#endif
], [],
[ac_cv_libva_sds_extensions="yes"],
[ac_cv_libva_sds_extensions="no"])
CFLAGS="$saved_CFLAGS"
])
VA_VERSION=`$PKG_CONFIG --modversion libva`
VA_MAJOR_VERSION=`echo "$VA_VERSION" | cut -d'.' -f1`
VA_MINOR_VERSION=`echo "$VA_VERSION" | cut -d'.' -f2`
VA_DRIVER_INIT_FUNC="__vaDriverInit_${VA_MAJOR_VERSION}_${VA_MINOR_VERSION}_sds"
if test "$ac_cv_libva_sds_extensions" = "yes"; then
AC_DEFINE_UNQUOTED([VA_DRIVER_INIT_FUNC], [$VA_DRIVER_INIT_FUNC], [Define driver entry-point])
else
AC_MSG_ERROR([Your VA API SDK does not include SDS extensions])
fi
AC_OUTPUT([
Makefile
gst-libs/Makefile
gst-libs/gst/Makefile
gst-libs/gst/vaapi/Makefile
sys/Makefile
sys/vaapi/Makefile
])
SUBDIRS = gst
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = Makefile.in
SUBDIRS = vaapi
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = Makefile.in
lib_LTLIBRARIES = libgstvaapi-@GST_MAJORMINOR@.la
libgstvaapi_@GST_MAJORMINOR@_la_SOURCES = \
$(NULL)
libgstvaapi_@GST_MAJORMINOR@includedir = \
$(includedir)/gstreamer-@GST_MAJORMINOR@/gst/vaapi
libgstvaapi_@GST_MAJORMINOR@include_HEADERS = \
$(NULL)
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = Makefile.in
SUBDIRS = vaapi
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = Makefile.in
plugin_LTLIBRARIES = libgstvaapisink.la
libgstvaapisink_la_SOURCES = \
$(NULL)
noinst_HEADERS = \
$(NULL)
libgstvaapisink_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
libgstvaapisink_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS)
libgstvaapisink_la_LDFLAGS =
libgstvaapisink_la_LIBTOOLFLAGS = --tag=disable-static
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = Makefile.in
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment