Commit e804ef4d authored by Sebastian Dröge's avatar Sebastian Dröge 🍵

Switch to Rust 1.31 as minimum supported version

Too many dependencies switched and we can't really keep everything at an
older version.

Commented out for now until stable becomes 1.32.
parent a99f71bb
......@@ -48,10 +48,10 @@ stages:
- cargo build --color=always --all --all-features
- G_DEBUG=fatal_warnings cargo test --color=always --all --all-features
test 1.28:
# 1.28 img
.test 1.31:
# 1.31 img
# https://hub.docker.com/_/rust/
image: "rust:1.28-slim"
image: "rust:1.31-slim"
<<: *cargo_test
test stable:
......
......@@ -29,11 +29,6 @@ pangocairo = { git = "https://github.com/gtk-rs/pangocairo", optional = true }
# Using my personal repository (vjaquez) for glutin until
# https://github.com/tomaka/glutin/pull/1082 is merged
glutin = { git = "https://github.com/ceyusa/glutin", branch="native-display", optional = true }
# Newer versions do not compile with rustc 1.28 so pin it for the time being
# This dependency comes from backtrace, which comes from failure
rustc-demangle = "0.1.10"
# This dependency comes from glutin and winit, which comes from failure
stb_truetype = { version = "= 0.2.4", optional = true }
[build-dependencies]
gl_generator = { version = "0.9", optional = true }
......
......@@ -14,9 +14,6 @@ gstreamer-app = { path = "../gstreamer-app" }
gstreamer-pbutils = { path = "../gstreamer-pbutils" }
byte-slice-cast = "0.2"
failure = "0.1.0"
# Newer versions do not compile with rustc 1.28 so pin it for the time being
# This dependency comes from backtrace, which comes from failure
rustc-demangle = "0.1.10"
[features]
tutorial5 = ["gtk", "gdk"]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment