Commit 706bf668 authored by Sebastian Dröge's avatar Sebastian Dröge 🍵

Require GIT versions of glib-sys/gobject-sys

Otherwise development against GIT versions of glib-rs are not possible
due to linking in different versions of the same crate.
parent c7582139
......@@ -4,8 +4,8 @@ pkg-config = "0.3.7"
[dependencies]
bitflags = "0.8"
libc = "0.2"
glib-sys = "0.3.4"
gobject-sys = "0.3.4"
glib-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
gobject-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
[dependencies.gstreamer-sys]
path = "../gstreamer-sys"
......
......@@ -4,8 +4,8 @@ pkg-config = "0.3.7"
[dependencies]
bitflags = "0.8"
libc = "0.2"
glib-sys = "0.3.4"
gobject-sys = "0.3.4"
glib-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
gobject-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
[dependencies.gstreamer-sys]
path = "../gstreamer-sys"
......
......@@ -4,8 +4,8 @@ pkg-config = "0.3.7"
[dependencies]
bitflags = "0.8"
libc = "0.2"
glib-sys = "0.3.4"
gobject-sys = "0.3.4"
glib-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
gobject-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
[dependencies.gstreamer-sys]
path = "../gstreamer-sys"
......
......@@ -4,8 +4,8 @@ pkg-config = "0.3.7"
[dependencies]
bitflags = "0.8"
libc = "0.2"
glib-sys = "0.3.4"
gobject-sys = "0.3.4"
glib-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
gobject-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
[dependencies.gstreamer-sys]
path = "../gstreamer-sys"
......
......@@ -4,8 +4,8 @@ pkg-config = "0.3.7"
[dependencies]
bitflags = "0.8"
libc = "0.2"
glib-sys = "0.3.4"
gobject-sys = "0.3.4"
glib-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
gobject-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
[features]
v1_0_10 = []
......
......@@ -4,8 +4,8 @@ pkg-config = "0.3.7"
[dependencies]
bitflags = "0.8"
libc = "0.2"
glib-sys = "0.3.4"
gobject-sys = "0.3.4"
glib-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
gobject-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
[dependencies.gstreamer-sys]
path = "../gstreamer-sys"
......
......@@ -4,8 +4,8 @@ pkg-config = "0.3.7"
[dependencies]
bitflags = "0.8"
libc = "0.2"
glib-sys = "0.3.4"
gobject-sys = "0.3.4"
glib-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
gobject-sys = { version = "0.3.4", git = "https://github.com/gtk-rs/sys" }
[dependencies.gstreamer-sys]
path = "../gstreamer-sys"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment