Commit 6de1ca7e authored by Sebastian Dröge's avatar Sebastian Dröge 🍵

video/gif: Update gif dependency to 0.11

parent 3b5d9b73
Pipeline #204570 failed with stages
in 14 minutes and 18 seconds
......@@ -12,7 +12,7 @@ glib = { git = "https://github.com/gtk-rs/glib" }
gstreamer = { git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs" }
gstreamer-video = { git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs" }
gstreamer-check = { git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs" }
gif = "0.10"
gif = "0.11"
atomic_refcell = "0.1"
once_cell = "1"
......
......@@ -7,7 +7,6 @@
// except according to those terms.
use atomic_refcell::AtomicRefCell;
use gif::SetParameter;
use glib::subclass;
use glib::subclass::prelude::*;
use gst::subclass::prelude::*;
......@@ -123,8 +122,8 @@ impl State {
)
.expect("Failed to initialize GIF encoder");
match settings.repeat {
-1 => encoder.set(gif::Repeat::Infinite),
_ => encoder.set(gif::Repeat::Finite(settings.repeat as u16)),
-1 => encoder.set_repeat(gif::Repeat::Infinite),
_ => encoder.set_repeat(gif::Repeat::Finite(settings.repeat as u16)),
}
.expect("Failed to configure encoder");
self.context = Some(encoder);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment