Commit 79f9f9e6 authored by Carlos Rafael Giani's avatar Carlos Rafael Giani Committed by Nicolas Dufresne

configure: Add configure checks for libdrm and gudev

https://bugzilla.gnome.org/show_bug.cgi?id=782923
parent 09584edc
......@@ -295,8 +295,17 @@ GST_PREFIX="`$PKG_CONFIG --variable=prefix gstreamer-$GST_API_VERSION`"
AC_SUBST(GLIB_PREFIX)
AC_SUBST(GST_PREFIX)
dnl check for libdrm
PKG_CHECK_MODULES(DRM, libdrm >= 2.4.55, HAVE_DRM=yes, HAVE_DRM=no)
AG_GST_GL_CHECKS
dnl check for gudev
PKG_CHECK_MODULES(G_UDEV, gudev-1.0 , [
AC_DEFINE([HAVE_GUDEV], 1, [Define if gudev is installed])
HAVE_GUDEV="yes" ],
[HAVE_GUDEV="no"])
dnl GTK is optional and only used in examples
HAVE_GTK=no
HAVE_GTK_X11=no
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment