Commit 59fe9c91 authored by Tim-Philipp Müller's avatar Tim-Philipp Müller 🐠

gl: remove GST_USE_UNSTABLE_API bits

parent 729b5002
......@@ -47,7 +47,7 @@ opengl_sources = [
if build_gstgl and gstgl_dep.found()
optional_deps = []
opengl_defines = ['-DGST_USE_UNSTABLE_API']
opengl_defines = []
if gl_dep.found() # have desktop GL
opengl_sources += [
......
......@@ -187,7 +187,6 @@ GstGL-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstgl-@GST_API_VERSION@
--pkg gstreamer-video-@GST_API_VERSION@ \
--pkg-export gstreamer-gl-@GST_API_VERSION@ \
--add-init-section="$(INTROSPECTION_INIT)" \
-DGST_USE_UNSTABLE_API \
--output $@ \
$(gir_headers) \
$(gir_sources)
......
......@@ -21,11 +21,6 @@
#ifndef __GST_GL_H__
#define __GST_GL_H__
#ifndef GST_USE_UNSTABLE_API
#warning "The GL library from gst-plugins-bad is unstable API and may change in future."
#warning "You can define GST_USE_UNSTABLE_API to avoid this warning."
#endif
#include <gst/gl/gstgl_fwd.h>
#include <gst/gl/gstglapi.h>
#include <gst/gl/gstglconfig.h>
......
......@@ -144,7 +144,7 @@ gl_winsys_deps = []
# other things we need.
gl_misc_deps = []
# Other preprocessor arguments
gl_cpp_args = ['-DGST_USE_UNSTABLE_API', '-DGST_EXPORTS']
gl_cpp_args = ['-DGST_EXPORTS']
enabled_gl_apis = []
enabled_gl_platforms = []
......@@ -687,8 +687,7 @@ if build_gstgl
export_packages : 'gstreamer-gl-1.0',
includes : ['Gst-1.0', 'GstBase-1.0', 'GstVideo-1.0'],
install : true,
extra_args : gir_init_section + ['-DGST_USE_UNSTABLE_API',
'--c-include=gst/gl/gl.h'],
extra_args : gir_init_section + ['--c-include=gst/gl/gl.h'],
dependencies : [gst_dep, gstbase_dep, gstvideo_dep]
)
gen_sources += gl_gir
......
......@@ -19,8 +19,6 @@
*/
#include <string.h>
#define GST_USE_UNSTABLE_API 1
#include <gst/gst.h>
#include <gtk/gtk.h>
#include <gdk/gdk.h>
......
......@@ -3,14 +3,10 @@ if sdl_dep.found() and build_gstgl
executable('sdlshare',
'sdlshare.c',
install: false,
dependencies : [gstbase_dep, gstgl_dep, sdl_dep, gl_dep],
c_args : ['-DGST_USE_UNSTABLE_API', ],
)
dependencies : [gstbase_dep, gstgl_dep, sdl_dep, gl_dep])
executable('sdlshare2',
'sdlshare2.c',
install: false,
dependencies : [gstbase_dep, gstgl_dep, sdl_dep, gl_dep],
c_args : ['-DGST_USE_UNSTABLE_API', ],
)
dependencies : [gstbase_dep, gstgl_dep, sdl_dep, gl_dep])
endif
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment