Commit 21d34edb authored by Sebastian Dröge's avatar Sebastian Dröge 🍵

pbutils: Add audio, base and video library to Requires line in the pkg-config file

We use all those libraries internally and include headers from them in
the public headers.

And add the tag library to Requires.private as we use it internally and
it would be needed when doing static linking.

Fixes gstreamer/gst-plugins-base#537
parent e48b8033
Pipeline #14857 passed with stages
in 70 minutes and 52 seconds
......@@ -10,7 +10,8 @@ typelibdir=@abs_top_builddir@/gst-libs/gst/pbutils
Name: GStreamer Base Utils Library, Uninstalled
Description: General utility functions, uninstalled
Version: @VERSION@
Requires: gstreamer-@GST_API_VERSION@
Requires: gstreamer-@GST_API_VERSION@ gstreamer-audio-@GST_API_VERSION@ gstreamer-base-@GST_API_VERSION@ gstreamer-video-@GST_API_VERSION@
Requires.private: gstreamer-tag-@GST_API_VERSION@
Libs: -L${libdir} -lgstpbutils-@GST_API_VERSION@
Cflags: -I@abs_top_srcdir@/gst-libs -I@abs_top_builddir@/gst-libs
......@@ -9,7 +9,8 @@ typelibdir=${libdir}/girepository-1.0
Name: GStreamer Base Utils Library
Description: General utility functions
Requires: gstreamer-@GST_API_VERSION@
Requires: gstreamer-@GST_API_VERSION@ gstreamer-audio-@GST_API_VERSION@ gstreamer-base-@GST_API_VERSION@ gstreamer-video-@GST_API_VERSION@
Requires.private: gstreamer-tag-@GST_API_VERSION@
Version: @VERSION@
Libs: -L${libdir} -lgstpbutils-@GST_API_VERSION@
Cflags: -I${includedir}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment