Export only gst_plugin_desc from plugins

Original commit message from CVS:
Export only gst_plugin_desc from plugins
parent b1907b35
2004-02-22 Ramon Garcia <ramon_garcia_f@yahoo.com>
* configure.ac: Export only gst_plugin_desc from plugins.
Note that this change only makes any effect with Linux using libtool
1.5.2 or higher. Otherwise it is silently ignored, but it would build
fine. And don't try to have several versions of libtool in different
directories.
2004-02-20 Andy Wingo <wingo@pobox.com>
* gst/intfloat/, gst/oneton: Removed, replaced by audioconvert and
......
......@@ -65,7 +65,7 @@ dnl decide on error flags
AS_COMPILER_FLAG(-Wall, GST_WALL="yes", GST_WALL="no")
if test "x$GST_WALL" = "xyes"; then
GST_ERROR="$GST_ERROR -Wall"
GST_ERROR="$GST_ERROR -Wall -Wno-sign-compare"
if test "x$GST_CVS" = "xyes"; then
AS_COMPILER_FLAG(-Werror,GST_ERROR="$GST_ERROR -Werror",GST_ERROR="$GST_ERROR")
......@@ -326,7 +326,7 @@ dnl ===========================================================================
plugindir="\$(libdir)/gstreamer-$GST_MAJORMINOR"
AC_SUBST(plugindir)
GST_PLUGIN_LDFLAGS='-module -avoid-version'
GST_PLUGIN_LDFLAGS='-module -avoid-version -export-symbols-regex gst_plugin_desc'
AC_SUBST(GST_PLUGIN_LDFLAGS)
dnl these are all the gst plug-ins, compilable without additional libs
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment