Commit 75ca48b6 authored by Christian Schaller's avatar Christian Schaller

apply Jeroens patch to move us to mpeg2dec 0.3.1, also update REQ file and spec file.

Original commit message from CVS:
apply Jeroens patch to move us to mpeg2dec 0.3.1, also update REQ file and spec file.
parent 1f1d9b87
......@@ -43,7 +43,7 @@ DIST_SUBDIRS=gst-libs gst sys ext examples tools gconf testsuite
EXTRA_DIST=gst-plugins.spec depcomp gst-element-check.m4 \
gstreamer-libs.pc.in gstreamer-libs-uninstalled.pc.in \
gstreamer-play.pc.in gstreamer-play-uninstalled.pc.in \
AUTHORS COPYING README RELEASE \
AUTHORS COPYING README RELEASE REQUIREMENTS \
ChangeLog autogen.sh common m4
dist-hook:
......
......@@ -33,7 +33,7 @@ libHermes (for colorspace conversions; you need this for any video work)
http://www.clanlib.org/hermes/
libghttp (for httpsrc)
http://ftp.gnome.org/pub/GNOME/stable/sources/libghttp/
libaudiofile (for afsrc/afsink)
libaudiofile (for afsrc/afsink
http://oss.sgi.com/projects/audiofile/
libmad (for the mad mp3 decoder plugin)
http://www.mars.org/home/rob/proj/mpeg/
......@@ -54,7 +54,7 @@ libshout (for the shoutcast plugin)
http://www.icecast.org
libasound (for the alsa src/sink plugin)
http://alsa-project.org/
ortp (for the rtp sink plugin)
librtp (for the rtp sink plugin)
http://www.linphone.org/ortp/
aalib (for the aa sink plugin)
http://aa-project.sourceforge.net/aalib/
......@@ -78,12 +78,6 @@ mpeg2dec/a52dec (for mpeg2 related plugins and dvd playback)
http://libmpeg2.sourceforge.net/
and http://liba52.sourceforge.net/
>= v0.3.0/v0.7.2
avifile (for the avi windows decoder plugins)
http://avifile.sourceforge.net/
you might want to get the windows libraries
from http://divx.euro.ru/ and put the .dll files
in /usr/lib/win32/
>= 0.6.0 (cvs)
libswfdec (for the swfdec plugin)
ftp://ftp.comedi.org/pub/libswfdec/
>= 0.1.1
......
......@@ -704,24 +704,10 @@ GST_CHECK_FEATURE(MJPEGTOOLS, [mjpegtools], jpegmmxenc jpegmmxdec, [
dnl *** mpeg2dec ***
translit(dnm, m, l) AM_CONDITIONAL(USE_MPEG2DEC, true)
GST_CHECK_FEATURE(MPEG2DEC, [mpeg2dec], mpeg2dec, [
PKG_CHECK_MODULES(LIBMPEG2, libmpeg2 >= 0.3.0,
HAVE_LIBMPEG2="yes", HAVE_LIBMPEG2="no")
AC_SUBST(LIBMPEG2_CFLAGS)
AC_SUBST(LIBMPEG2_LIBS)
PKG_CHECK_MODULES(LIBCPUACCEL, libcpuaccel >= 0.3.0,
HAVE_LIBCPUACCEL="yes", HAVE_LIBCPUACCEL="no")
AC_SUBST(LIBCPUACCEL_CFLAGS)
AC_SUBST(LIBCPUACCEL_LIBS)
HAVE_MPEG2DEC="no"
if test x$HAVE_LIBMPEG2 = xyes -a x$HAVE_LIBCPUACCEL = xyes; then
HAVE_MPEG2DEC="yes"
MPEG2DEC_CFLAGS="$LIBMPEG2_CFLAGS $LIBCPUACCEL_CFLAGS"
MPEG2DEC_LIBS="$LIBMPEG2_LIBS $LIBCPUACCEL_LIBS"
PKG_CHECK_MODULES(MPEG2DEC, libmpeg2 >= 0.3.0,
HAVE_MPEG2DEC="yes", HAVE_MPEG2DEC="no")
AC_SUBST(MPEG2DEC_CFLAGS)
AC_SUBST(MPEG2DEC_LIBS)
fi
])
dnl *** openquicktime ***
......
......@@ -822,8 +822,8 @@ Plug-ins for playback of AVI format media files.
@USE_MPEG2DEC_TRUE@Summary:GStreamer plug-ins for MPEG video playback and encoding.
@USE_MPEG2DEC_TRUE@Group: Libraries/Multimedia
@USE_MPEG2DEC_TRUE@Requires: gstreamer-plugins = %{version}
@USE_MPEG2DEC_TRUE@Requires: mpeg2dec => 0.2.1
@USE_MPEG2DEC_TRUE@BuildRequires: mpeg2dec-devel => 0.2.1
@USE_MPEG2DEC_TRUE@Requires: mpeg2dec => 0.3.1
@USE_MPEG2DEC_TRUE@BuildRequires: mpeg2dec-devel => 0.3.1
@USE_MPEG2DEC_TRUE@Obsoletes: gstreamer-mpeg1
@USE_MPEG2DEC_TRUE@Obsoletes: gstreamer-mpeg2
@USE_MPEG2DEC_TRUE@Obsoletes: gstreamer-mpeg2dec
......@@ -1530,6 +1530,8 @@ This package contains a basic audio and video playback library.
/sbin/ldconfig
%changelog
* Sun Dec 15 2002 Christian Schaller <Uraeus@linuxrising.org>
- Update mpeg2dec REQ to be 0.3.1
* Tue Dec 10 2002 Thomas Vander Stichele <thomas at apestaart dot org>
- only install schema once
- move out devel lib stuff to -devel package
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment