Commit afdbe664 authored by Sebastian Dröge's avatar Sebastian Dröge 🍵

Release 1.5.2

parent c44f1a95
=== release 1.5.2 ===
2015-06-24 Sebastian Dröge <slomo@coaxion.net>
* configure.ac:
releasing 1.5.2
2015-06-16 17:50:03 -0400 Nicolas Dufresne <nicolas.dufresne@collabora.co.uk>
* common:
Automatic update of common submodule
From 6015d26 to f74b2df
2015-06-04 19:11:02 -0400 Nicolas Dufresne <nicolas.dufresne@collabora.com>
* ext/libav/gstavcodecmap.c:
avcodec: Check against codec format list
There exist few formats (deprecated though) used by mjpeg decoder
and encoder that maps to the same GStreamer format. To properly
pick the right format, also lookup each Codec list before accepting
the format. This fixes error when trying to use mjpeg encoder.
Note that this may results in faded colors. In fact, these special
format are meant to specify that this is full range YUV. Colorimetry
in gst-libav is not yet implemented, hence is ignored in general. So
I think it's fine to first fix the issue before addressing the missing
feature.
https://bugzilla.gnome.org/show_bug.cgi?id=750398
2014-10-07 16:33:07 +1100 Jan Schmidt <jan@centricular.com>
* ext/libav/gstavviddec.c:
viddec: Replicate any 3D/multiview info from input caps onto output
2015-06-09 15:41:46 +0200 Stefan Sauer <ensonic@users.sf.net>
* Makefile.am:
cruft: add the obsolete tmpl dir to cruft-dirs
2015-06-09 11:30:44 +0200 Edward Hervey <bilboed@bilboed.com>
* common:
Automatic update of common submodule
From d9a3353 to 6015d26
2015-06-08 23:08:20 +0200 Stefan Sauer <ensonic@users.sf.net>
* common:
Automatic update of common submodule
From d37af32 to d9a3353
2015-06-07 23:06:58 +0200 Stefan Sauer <ensonic@users.sf.net>
* common:
Automatic update of common submodule
From 21ba2e5 to d37af32
2015-06-07 17:32:20 +0200 Stefan Sauer <ensonic@users.sf.net>
* common:
Automatic update of common submodule
From c408583 to 21ba2e5
2015-06-07 17:03:46 +0200 Stefan Sauer <ensonic@users.sf.net>
* docs/plugins/Makefile.am:
docs: remove variables that we define in the snippet from common
This is syncing our Makefile.am with upstream gtkdoc.
2015-06-07 17:16:38 +0200 Stefan Sauer <ensonic@users.sf.net>
* autogen.sh:
* common:
Automatic update of common submodule
From c8fb372 to c408583
2015-06-07 16:44:49 +0200 Sebastian Dröge <sebastian@centricular.com>
* configure.ac:
Back to development
=== release 1.5.1 === === release 1.5.1 ===
2015-06-07 Sebastian Dröge <slomo@coaxion.net> 2015-06-07 11:10:59 +0200 Sebastian Dröge <sebastian@centricular.com>
* ChangeLog:
* NEWS:
* RELEASE:
* configure.ac: * configure.ac:
releasing 1.5.1 * docs/plugins/gst-libav-plugins.args:
* docs/plugins/gst-libav-plugins.hierarchy:
* docs/plugins/gst-libav-plugins.interfaces:
* docs/plugins/inspect/plugin-libav.xml:
* gst-libav.doap:
Release 1.5.1
2015-06-05 11:57:37 +0200 Sebastian Dröge <sebastian@centricular.com> 2015-06-05 11:57:37 +0200 Sebastian Dröge <sebastian@centricular.com>
......
This is GStreamer Libav Plugins 1.5.1 This is GStreamer Libav Plugins 1.5.2
Release notes for GStreamer libav Plugins 1.5.1 Release notes for GStreamer libav Plugins 1.5.2
The GStreamer team is pleased to announce the first release of the unstable The GStreamer team is pleased to announce the second release of the unstable
1.5 release series. The 1.5 release series is adding new features on top of 1.5 release series. The 1.5 release series is adding new features on top of
the 1.0, 1.2 and 1.4 series and is part of the API and ABI-stable 1.x release the 1.0, 1.2 and 1.4 series and is part of the API and ABI-stable 1.x release
series of the GStreamer multimedia framework. The unstable 1.5 release series series of the GStreamer multimedia framework. The unstable 1.5 release series
...@@ -40,9 +40,7 @@ contains a set of less supported plugins that haven't passed the ...@@ -40,9 +40,7 @@ contains a set of less supported plugins that haven't passed the
Bugs fixed in this release Bugs fixed in this release
* 676131 : avdec_aac should be ranked above faad * 750398 : avenc_mjpeg fails to negotiate the source format
* 726020 : avdec_h265: freezes when max-threads != 1
* 740822 : av: use GMutex instead of deprecated GStaticMutex
==== Download ==== ==== Download ====
...@@ -79,17 +77,9 @@ subscribe to the gstreamer-devel list. ...@@ -79,17 +77,9 @@ subscribe to the gstreamer-devel list.
Contributors to this release Contributors to this release
* Aleix Conchillo Flaqué
* Aurélien Zanelli
* Edward Hervey * Edward Hervey
* IBM Thinklab
* Jan Schmidt * Jan Schmidt
* Luis de Bethencourt
* Mark Nauwelaerts
* Nicolas Dufresne * Nicolas Dufresne
* Olivier Crête
* Sebastian Dröge * Sebastian Dröge
* Stefan Sauer * Stefan Sauer
* Thibault Saunier
* Tim-Philipp Müller
   
\ No newline at end of file
...@@ -3,7 +3,7 @@ AC_PREREQ(2.69) ...@@ -3,7 +3,7 @@ AC_PREREQ(2.69)
dnl initialize autoconf dnl initialize autoconf
dnl when going to/from release please set the nano (fourth number) right ! dnl when going to/from release please set the nano (fourth number) right !
dnl releases only do Wall, cvs and prerelease does Werror too dnl releases only do Wall, cvs and prerelease does Werror too
AC_INIT(GStreamer libav, 1.5.1.1, AC_INIT(GStreamer libav, 1.5.2,
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer, http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer,
gst-libav) gst-libav)
...@@ -40,11 +40,11 @@ GST_API_VERSION=1.0 ...@@ -40,11 +40,11 @@ GST_API_VERSION=1.0
AC_SUBST(GST_API_VERSION) AC_SUBST(GST_API_VERSION)
AG_GST_LIBTOOL_PREPARE AG_GST_LIBTOOL_PREPARE
AS_LIBTOOL(GST, 501, 0, 501) AS_LIBTOOL(GST, 502, 0, 502)
dnl *** required versions of GStreamer stuff *** dnl *** required versions of GStreamer stuff ***
GST_REQ=1.5.1.1 GST_REQ=1.5.2
GST_PBREQ=1.5.1.1 GST_PBREQ=1.5.2
ORC_REQ=0.4.16 ORC_REQ=0.4.16
ORC_CHECK([$ORC_REQ]) ORC_CHECK([$ORC_REQ])
......
...@@ -135,8 +135,6 @@ GObject ...@@ -135,8 +135,6 @@ GObject
avenc_roq_dpcm avenc_roq_dpcm
avenc_wmav1 avenc_wmav1
avenc_wmav2 avenc_wmav2
GstBaseTransform
GstFFMpegScale
GstBin GstBin
GstPipeline GstPipeline
GstFFMpegDeinterlace GstFFMpegDeinterlace
......
...@@ -3,7 +3,7 @@ ...@@ -3,7 +3,7 @@
<description>All libav codecs and formats (local snapshot)</description> <description>All libav codecs and formats (local snapshot)</description>
<filename>../../ext/libav/.libs/libgstlibav.so</filename> <filename>../../ext/libav/.libs/libgstlibav.so</filename>
<basename>libgstlibav.so</basename> <basename>libgstlibav.so</basename>
<version>1.5.1</version> <version>1.5.2</version>
<license>GPL</license> <license>GPL</license>
<source>gst-libav</source> <source>gst-libav</source>
<package>libav</package> <package>libav</package>
......
...@@ -32,6 +32,16 @@ colorspace conversion elements. ...@@ -32,6 +32,16 @@ colorspace conversion elements.
</GitRepository> </GitRepository>
</repository> </repository>
<release>
<Version>
<revision>1.5.2</revision>
<branch>1.5</branch>
<name></name>
<created>2015-06-24</created>
<file-release rdf:resource="http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-1.5.2.tar.xz" />
</Version>
</release>
<release> <release>
<Version> <Version>
<revision>1.5.1</revision> <revision>1.5.1</revision>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment