Commit af8cc8ab authored by Tim-Philipp Müller's avatar Tim-Philipp Müller 🐠

Release 1.13.90

parent d95750da
This diff is collapsed.
This diff is collapsed.
This is GStreamer gst-libav 1.13.90.
Release notes for GStreamer libav Plugins 1.12.0 The GStreamer team is pleased to announce the first release candidate for the
upcoming stable 1.14 release series.
The GStreamer team is pleased to announce the first release in the stable 1.12 The 1.14 release series adds new features on top of the 1.0, 1.2, 1.4, 1.6,
release series. The 1.12 release series is adding new features on top of the 1.8, 1.10 and 1.12 series and is part of the API and ABI-stable 1.x release
1.0, 1.2, 1.4, 1.6, 1.8 and 1.10 series and is part of the API and ABI-stable series of the GStreamer multimedia framework.
1.x release series of the GStreamer multimedia framework.
Full release notes can be found at:
Full release notes can be found here https://gstreamer.freedesktop.org/releases/1.14/
Binaries for Android, iOS, Mac OS X and Windows will be provided shortly
after the release.
Binaries for Android, iOS, Mac OS X and Windows will be provided in the next days. This module will not be very useful by itself and should be used in conjunction
with other GStreamer modules for a complete multimedia experience.
- gstreamer: provides the core GStreamer libraries and some generic plugins
This module contains plugins based on the ffmpeg project, including codecs. - gst-plugins-base: a basic set of well-supported plugins and additional
media-specific GStreamer helper libraries for audio,
video, rtsp, rtp, tags, OpenGL, etc.
- gst-plugins-good: a set of well-supported plugins under our preferred
license
- gst-plugins-ugly: a set of well-supported plugins which might pose
problems for distributors
Other modules containing plugins are: - gst-plugins-bad: a set of plugins of varying quality that have not made
their way into one of core/base/good/ugly yet, for one
reason or another. Many of these are are production quality
elements, but may still be missing documentation or unit
tests; others haven't passed the rigorous quality testing
we expect yet.
- gst-libav: a set of codecs plugins based on the ffmpeg library. This is
where you can find audio and video decoders and encoders
for a wide variety of formats including H.264, AAC, etc.
gst-plugins-base - gstreamer-vaapi: hardware-accelerated video decoding and encoding using
contains a basic set of well-supported plugins VA-API on Linux. Primarily for Intel graphics hardware.
gst-plugins-good
contains a set of well-supported plugins under our preferred license
gst-plugins-ugly
contains a set of well-supported plugins, but might pose problems for
distributors
gst-plugins-bad
contains a set of less supported plugins that haven't passed the
rigorous quality testing we expect, or are still missing documentation
and/or unit tests
- gst-omx: hardware-accelerated video decoding and encoding, primarily for
embedded Linux systems that provide an OpenMax
implementation layer such as the Raspberry Pi.
- gst-rtsp-server: library to serve files or streaming pipelines via RTSP
- gst-editing-services: library an plugins for non-linear editing
==== Download ==== ==== Download ====
You can find source releases of gst-libav in the download You can find source releases of gstreamer in the download
directory: https://gstreamer.freedesktop.org/src/gst-libav/ directory: https://gstreamer.freedesktop.org/src/gstreamer/
The git repository and details how to clone it can be found at The git repository and details how to clone it can be found at
http://cgit.freedesktop.org/gstreamer/gst-libav/ http://cgit.freedesktop.org/gstreamer/gstreamer/
==== Homepage ==== ==== Homepage ====
...@@ -67,12 +82,3 @@ from there (see link above). ...@@ -67,12 +82,3 @@ from there (see link above).
Interested developers of the core library, plugins, and applications should Interested developers of the core library, plugins, and applications should
subscribe to the gstreamer-devel list. subscribe to the gstreamer-devel list.
Contributors to this release
* Edward Hervey
* Jan Schmidt
* Sebastian Dröge
* Tim-Philipp Müller
 
\ No newline at end of file
...@@ -3,7 +3,7 @@ AC_PREREQ(2.69) ...@@ -3,7 +3,7 @@ AC_PREREQ(2.69)
dnl initialize autoconf dnl initialize autoconf
dnl when going to/from release please set the nano (fourth number) right ! dnl when going to/from release please set the nano (fourth number) right !
dnl releases only do Wall, cvs and prerelease does Werror too dnl releases only do Wall, cvs and prerelease does Werror too
AC_INIT(GStreamer libav, 1.13.1.1, AC_INIT(GStreamer libav, 1.13.90,
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer, http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer,
gst-libav) gst-libav)
...@@ -42,11 +42,11 @@ AC_SUBST(GST_API_VERSION) ...@@ -42,11 +42,11 @@ AC_SUBST(GST_API_VERSION)
dnl *** Check for external $AS vs detected by AS_LIBTOOL dnl *** Check for external $AS vs detected by AS_LIBTOOL
user_AS="$AS" user_AS="$AS"
AG_GST_LIBTOOL_PREPARE AG_GST_LIBTOOL_PREPARE
AS_LIBTOOL(GST, 1301, 0, 1301) AS_LIBTOOL(GST, 1390, 0, 1390)
dnl *** required versions of GStreamer stuff *** dnl *** required versions of GStreamer stuff ***
GST_REQ=1.13.1.1 GST_REQ=1.13.90
GST_PBREQ=1.13.1.1 GST_PBREQ=1.13.90
ORC_REQ=0.4.16 ORC_REQ=0.4.16
ORC_CHECK([$ORC_REQ]) ORC_CHECK([$ORC_REQ])
......
...@@ -30,7 +30,17 @@ colorspace conversion elements. ...@@ -30,7 +30,17 @@ colorspace conversion elements.
<location rdf:resource="git://anongit.freedesktop.org/gstreamer/gst-libav"/> <location rdf:resource="git://anongit.freedesktop.org/gstreamer/gst-libav"/>
<browse rdf:resource="http://cgit.freedesktop.org/gstreamer/gst-libav"/> <browse rdf:resource="http://cgit.freedesktop.org/gstreamer/gst-libav"/>
</GitRepository> </GitRepository>
</repository> </repository>
<release>
<Version>
<revision>1.13.90</revision>
<branch>master</branch>
<name></name>
<created>2018-03-03</created>
<file-release rdf:resource="https://gstreamer.freedesktop.org/src/gst-libav/gst-libav-1.13.90.tar.xz" />
</Version>
</release>
<release> <release>
<Version> <Version>
......
project('gst-libav', 'c', 'cpp', project('gst-libav', 'c', 'cpp',
version : '1.13.1.1', version : '1.13.90',
meson_version : '>= 0.36.0', meson_version : '>= 0.36.0',
default_options : [ 'warning_level=1', default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ]) 'buildtype=debugoptimized' ])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment