Commit 79a9865c authored by Sebastian Dröge's avatar Sebastian Dröge 🍵

Release 1.3.90

parent d1acf1e5
=== release 1.3.90 ===
2014-06-28 Sebastian Dröge <slomo@coaxion.net>
* configure.ac:
releasing 1.3.90
2014-06-28 09:59:49 +0200 Sebastian Dröge <sebastian@centricular.com>
* gst-libs/ext/libav:
libav: Update to v10.2
2014-06-22 19:36:14 +0200 Sebastian Dröge <sebastian@centricular.com>
* configure.ac:
Back to development
=== release 1.3.3 ===
2014-06-22 Sebastian Dröge <slomo@coaxion.net>
2014-06-22 19:27:47 +0200 Sebastian Dröge <sebastian@centricular.com>
* ChangeLog:
* NEWS:
* RELEASE:
* configure.ac:
releasing 1.3.3
* docs/plugins/inspect/plugin-libav.xml:
* gst-libav.doap:
Release 1.3.3
2014-06-21 18:29:32 +0200 Sebastian Dröge <sebastian@centricular.com>
......
This is GStreamer Libav Plugins 1.3.3
This is GStreamer Libav Plugins 1.3.90
Changes since 1.2:
......@@ -129,7 +129,7 @@ Major changes:
with downstream via caps.
∘ Lots of fixes for coverity warnings all over the place.
∘ Negotiation related performance improvements.
500+ fixed bug reports, and many other bug fixes and other
800+ fixed bug reports, and many other bug fixes and other
improvements everywhere that had no bug report.
Things to look out for:
......@@ -137,5 +137,9 @@ Things to look out for:
element.
• The mfcdec element was removed and replaced by v4l2videodec.
• osxvideosink is only available in OS X 10.6 or newer.
• The GstDeviceMonitor API will likely change slightly before the
1.4.0 release.
• On Android the namespace of the automatically generated Java class
for initialization of GStreamer has changed from com.gstreamer to
org.freedesktop.gstreamer to prevent namespace pollution.
• On iOS you have to update your gst_ios_init.h and gst_ios_init.m in
your projects from the one included in the binaries if you used the
GnuTLS GIO module before. The loading mechanism has slightly changed.
Release notes for GStreamer libav Plugins 1.3.3
Release notes for GStreamer libav Plugins 1.3.90
The GStreamer team is pleased to announce the third release of the unstable
1.3 release series. The 1.3 release series is adding new features on top of
the 1.0 and 1.2 series and is part of the API and ABI-stable 1.x release
series of the GStreamer multimedia framework. The unstable 1.3 release series
will lead to the stable 1.4 release series in the next weeks, and newly added
API can still change until that point.
The GStreamer team is pleased to announce the first release candidate of
the stable 1.4 release series. The 1.4 release series is adding new features
on top of the 1.0 and 1.2 series and is part of the API and ABI-stable 1.x
release series of the GStreamer multimedia framework.
This is hopefully the last 1.3 development release and will be followed by
the first 1.4.0 release candidate (1.3.90) in 1-2 weeks. Which then hopefully
is followed by 1.4.0 soonish in early July.
This release candidate will hopefully shortly be followed by the stable 1.4.0
release if no bigger regressions or bigger issues are detected, and enough
testing of the release candidate happened. The new API that was added during
the 1.3 release series is not expected to change anymore at this point.
Binaries for Android, iOS, Mac OS X and Windows are provided together with this
release.
The stable 1.4 release series is API and ABI compatible with 1.0.x, 1.2.x and
any other 1.x release series in the future. Compared to 1.2.x it contains some
new features and more intrusive changes that were considered too risky as a
bugfix.
Binaries for Android, iOS, Mac OS X and Windows will be provided separately
during the unstable 1.3 release series.
This module contains plugins based on the libav project, including codecs.
......@@ -41,10 +48,8 @@ contains a set of less supported plugins that haven't passed the
Bugs fixed in this release
* 651320 : avenc_mpeg4: Implement profile negotiation via caps
* 729268 : libav: avoid using wrong number of samples
There were no bugs fixed in this release
==== Download ====
......@@ -82,7 +87,4 @@ subscribe to the gstreamer-devel list.
Contributors to this release
* Sebastian Dröge
* Thiago Santos
* Vincent Penquerc'h
* Wim Taymans
 
\ No newline at end of file
......@@ -3,7 +3,7 @@ AC_PREREQ(2.62)
dnl initialize autoconf
dnl when going to/from release please set the nano (fourth number) right !
dnl releases only do Wall, cvs and prerelease does Werror too
AC_INIT(GStreamer libav, 1.3.3.1,
AC_INIT(GStreamer libav, 1.3.90,
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer,
gst-libav)
......@@ -42,11 +42,11 @@ GST_API_VERSION=1.0
AC_SUBST(GST_API_VERSION)
AG_GST_LIBTOOL_PREPARE
AS_LIBTOOL(GST, 303, 0, 303)
AS_LIBTOOL(GST, 390, 0, 390)
dnl *** required versions of GStreamer stuff ***
GST_REQ=1.3.3.1
GST_PBREQ=1.3.3.1
GST_REQ=1.3.90
GST_PBREQ=1.3.90
ORC_REQ=0.4.16
ORC_CHECK([$ORC_REQ])
......
......@@ -437,7 +437,7 @@ GObject
GstPadTemplate
GstPlugin
GstPluginFeature
GstDeviceMonitorFactory
GstDeviceProviderFactory
GstElementFactory
GstTypeFindFactory
GstRegistry
......
......@@ -3,7 +3,7 @@
<description>All libav codecs and formats (local snapshot)</description>
<filename>../../ext/libav/.libs/libgstlibav.so</filename>
<basename>libgstlibav.so</basename>
<version>1.3.3</version>
<version>1.3.90</version>
<license>GPL</license>
<source>gst-libav</source>
<package>libav</package>
......
......@@ -32,6 +32,16 @@ colorspace conversion elements.
</GitRepository>
</repository>
<release>
<Version>
<revision>1.3.90</revision>
<branch>1.3</branch>
<name></name>
<created>2014-06-28</created>
<file-release rdf:resource="http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-1.3.90.tar.xz" />
</Version>
</release>
<release>
<Version>
<revision>1.3.3</revision>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment