Commit 5d2e9b7b authored by Sebastian Dröge's avatar Sebastian Dröge 🍵

Make the LGPL build the default and require --enable-gpl to build a GPL licensed version

parent b526816c
......@@ -241,11 +241,11 @@ if test "x$HAVE_LZMA" = "xno"; then
AC_WARN([lzma not found, tiff reader will not be able to read lzma files])
fi
AC_ARG_ENABLE(lgpl,
[AC_HELP_STRING([--enable-lgpl], [build a LGPL licensed gst-libav])])
AM_CONDITIONAL(GST_LIBAV_ENABLE_LGPL, test "x$enable_lgpl" = "xyes")
if test "x$enable_lgpl" = "xyes"; then
AC_DEFINE([GST_LIBAV_ENABLE_LGPL], [], [Defined if building a LGPL-only version of gst-libav])
AC_ARG_ENABLE(gpl,
[AC_HELP_STRING([--enable-gpl], [build a GPL licensed gst-libav])])
AM_CONDITIONAL(GST_LIBAV_ENABLE_GPL, test "x$enable_gpl" = "xyes")
if test "x$enable_gpl" = "xyes"; then
AC_DEFINE([GST_LIBAV_ENABLE_GPL], [], [Defined if building a GPL-licensed version of gst-libav])
fi
dnl *** configure external libs ***
......@@ -325,7 +325,7 @@ else
--disable-network --disable-hwaccels --disable-dxva2 --disable-vdpau\
--disable-filters --disable-doc --enable-optimizations"
if test "x$enable_lgpl" != "xyes"; then
if test "x$enable_gpl" == "xyes"; then
emblibav_configure_args="$emblibav_configure_args --enable-gpl"
fi
......
......@@ -150,9 +150,9 @@ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
libav,
"All libav codecs and formats (" LIBAV_SOURCE ")",
plugin_init, PACKAGE_VERSION,
#ifdef GST_LIBAV_ENABLE_LGPL
"LGPL",
#else
#ifdef GST_LIBAV_ENABLE_GPL
"GPL",
#else
"LGPL",
#endif
"libav", "http://www.libav.org")
......@@ -743,9 +743,9 @@ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
avvideoscale,
"libav videoscaling element (" LIBAV_SOURCE ")", plugin_init,
PACKAGE_VERSION,
#ifdef GST_LIBAV_ENABLE_LGPL
"LGPL",
#else
#ifdef GST_LIBAV_ENABLE_GPL
"GPL",
#else
"LGPL",
#endif
"libav", "http://www.libav.org/")
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment