Commit 3423d0f5 authored by D Scott Phillips's avatar D Scott Phillips Committed by Thibault Saunier

meson: Include libav dependency in FFmpeg check

The FFmpeg-origin check can't work if it isn't provided the
dependency library.

https://bugzilla.gnome.org/show_bug.cgi?id=773911
parent 7f39f69c
......@@ -25,7 +25,7 @@ check_ffmpeg_src = '''#include <libavcodec/avcodec.h>
#error libav provider should be FFmpeg
#endif'''
if not cc.compiles(check_ffmpeg_src, name : 'libav is provided by FFmpeg')
if not cc.compiles(check_ffmpeg_src, dependencies : libav_deps, name : 'libav is provided by FFmpeg')
error('Uncompatible libavcodec found')
endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment