configure.ac 10.2 KB
Newer Older
1
AC_PREREQ(2.52)
2

3
dnl initialize autoconf
4
5
dnl when going to/from release please set the nano (fourth number) right !
dnl releases only do Wall, cvs and prerelease does Werror too
6
AC_INIT(GStreamer FFMpeg, 0.10.3.1,
7
8
9
    http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer,
    gst-ffmpeg)

10
11
AG_GST_INIT

12
13
dnl initialize automake
AM_INIT_AUTOMAKE
Thomas Vander Stichele's avatar
Thomas Vander Stichele committed
14

15
16
dnl define PACKAGE_VERSION_* variables
AS_VERSION
17

18
19
20
21
22
23
24
25
26
27
28
dnl check if this is a release version
AS_NANO(GST_CVS="no", GST_CVS="yes")

dnl can autoconf find the source ?
AC_CONFIG_SRCDIR([ext/ffmpeg/gstffmpeg.c])

dnl define the output header for config
AM_CONFIG_HEADER([config.h])

dnl AM_MAINTAINER_MODE only provides the option to configure to enable it
AM_MAINTAINER_MODE
Thomas Vander Stichele's avatar
Thomas Vander Stichele committed
29

30
31
dnl sets host_* variables
AC_CANONICAL_HOST
32
33

dnl our libraries and install dirs use major.minor as a version
34
35
GST_MAJORMINOR=$PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR
dnl we override it here if we need to for the release candidate of new series
Thomas Vander Stichele's avatar
Thomas Vander Stichele committed
36
GST_MAJORMINOR=0.10
37
AC_SUBST(GST_MAJORMINOR)
38
39
40
41

AM_PROG_LIBTOOL

dnl *** required versions of GStreamer stuff ***
42
GST_REQ=0.10.13
43
44
LIBOIL_MAJORMINOR=0.3
LIBOIL_REQ=0.3.6
45
46
47
48
49

dnl *** autotools stuff ****

dnl allow for different autotools
AS_AUTOTOOLS_ALTERNATE
50
51

dnl Add parameters for aclocal
52
53
54
55
AC_SUBST(ACLOCAL_AMFLAGS, "-I m4 -I common/m4")

dnl *** check for arguments to configure ***

56
57
58
AG_GST_ARG_WITH_PACKAGE_NAME
AG_GST_ARG_WITH_PACKAGE_ORIGIN
AG_GST_ARG_VALGRIND
59
60
61
62
63
64
65

dnl *** checks for platform ***

dnl * hardware/architecture *

dnl common/m4/gst-arch.m4
dnl check CPU type
66
AG_GST_ARCH
67
68

dnl *** checks for programs ***
69

70
dnl find a compiler
71
AC_PROG_CC
72
73

# FIXME: are these two lines needed ?
74
75
76
AM_PROG_CC_STDC
AS="${CC}"

77
78
79
dnl check if the compiler supports '-c' and '-o' options
AM_PROG_CC_C_O

80
81
82
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")

83
84
85
dnl check for documentation tools
GTK_DOC_CHECK([1.3])
AS_PATH_PYTHON([2.1])
86

87
dnl *** checks for libraries ***
88

89
90
91
92
dnl check for libm, for sin()
AC_CHECK_LIBM
AC_SUBST(LIBM)

93
dnl *** checks for header files ***
94

95
96
dnl check if we have ANSI C header files
AC_HEADER_STDC
97

98
dnl *** checks for types/defines ***
99

100
101
102
103
104
105
106
107
108
dnl *** checks for structures ***

dnl *** checks for compiler characteristics ***

dnl *** checks for library functions ***

dnl *** checks for dependancy libraries ***

dnl checks for gstreamer
109
dnl uninstalled is selected preferentially -- see pkg-config(1)
110
111
112
113
AG_GST_CHECK_GST($GST_MAJORMINOR, [$GST_REQ])
AG_GST_CHECK_GST_BASE($GST_MAJORMINOR, [$GST_REQ])
AG_GST_CHECK_GST_PLUGINS_BASE($GST_MAJORMINOR, [$GST_REQ])
AG_GST_CHECK_GST_CHECK($GST_MAJORMINOR, [$GST_REQ], no)
114
AM_CONDITIONAL(HAVE_GST_CHECK, test "x$HAVE_GST_CHECK" = "xyes")
115

116
117
118
AC_MSG_NOTICE(Using GStreamer Core Plugins in $GST_PLUGINS_DIR)
AC_MSG_NOTICE(Using GStreamer Base Plugins in $GSTPB_PLUGINS_DIR)

119
120
121
dnl liboil is required for cpu detection for libpostproc
dnl FIXME : In theory we should be able to compile libpostproc with cpudetect
dnl capabilities, which would enable us to get rid of this
122
123
124
PKG_CHECK_MODULES(LIBOIL, liboil-$LIBOIL_MAJORMINOR >= $LIBOIL_REQ, HAVE_LIBOIL=yes, HAVE_LIBOIL=no)
if test "x$HAVE_LIBOIL" != "xyes"
then
125
126
  AC_MSG_ERROR([liboil-$LIBOIL_REQ or later is required])
  AC_ERROR
127
128
129
130
131
fi

AC_SUBST(LIBOIL_CFLAGS)
AC_SUBST(LIBOIL_LIBS)

132
133
134
dnl *** set variables based on configure arguments ***

dnl set location of plugin directory
135
AG_GST_SET_PLUGINDIR
136
137

dnl define an ERROR_CFLAGS Makefile variable
138
AG_GST_SET_ERROR_CFLAGS($GST_CVS)
139
140

dnl define correct level for debugging messages
141
AG_GST_SET_LEVEL_DEFAULT($GST_CVS)
142
143
144
145
146
147
148
149
150
151
152
153
154
155

dnl *** finalize CFLAGS, LDFLAGS, LIBS ***

dnl Overview:
dnl GST_OPTION_CFLAGS:  common flags for profiling, debugging, errors, ...
dnl GST_*:              flags shared by built objects to link against GStreamer
dnl GST_ALL_LDFLAGS:    linker flags shared by all
dnl GST_LIB_LDFLAGS:    additional linker flags for all libaries
dnl GST_LT_LDFLAGS:     library versioning of our libraries
dnl GST_PLUGIN_LDFLAGS: flags to be used for all plugins

dnl GST_OPTION_CFLAGS
if test "x$USE_DEBUG" = xyes; then
   PROFILE_CFLAGS="-g"
156
fi
157
AC_SUBST(PROFILE_CFLAGS)
158

159
160
161
162
163
if test "x$GST_CVS" = "xyes"; then
  DEPRECATED_CFLAGS="-DGST_DISABLE_DEPRECATED"
else
  DEPRECATED_CFLAGS=""
fi
164
AC_SUBST(DEPRECATED_CFLAGS)
165

166
167
dnl every flag in GST_OPTION_CFLAGS can be overridden at make time
GST_OPTION_CFLAGS="\$(ERROR_CFLAGS) \$(DEBUG_CFLAGS) \$(PROFILE_CFLAGS) \$(GCOV_CFLAGS) \$(OPT_CFLAGS) \$(DEPRECATED_CFLAGS)"
168

169
AC_SUBST(GST_OPTION_CFLAGS)
170

171
172
173
174
175
176
177
dnl FIXME: do we want to rename to GST_ALL_* ?
dnl prefer internal headers to already installed ones
dnl also add builddir include for enumtypes and marshal
dnl add GST_OPTION_CFLAGS, but overridable
GST_CFLAGS="-I\$(top_srcdir)/gst-libs -I\$(top_builddir)/gst-libs $GST_CFLAGS \$(GST_OPTION_CFLAGS)"
AC_SUBST(GST_CFLAGS)
AC_SUBST(GST_LIBS)
178

179
180
181
GST_ALL_LDFLAGS="-no-undefined"
AC_SUBST(GST_ALL_LDFLAGS)

182
183
184
185
dnl this really should only contain flags, not libs - they get added before
dnl whatevertarget_LIBS and -L flags here affect the rest of the linking
GST_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '^[_]*gst_plugin_desc\$\$' $GST_ALL_LDFLAGS"
AC_SUBST(GST_PLUGIN_LDFLAGS)
186

187
188
189
190
191
192
193
194
195
196
197
198
dnl Add MacOSX specific flags
AC_CANONICAL_HOST
case $host_os in
     darwin*)
	DARWIN_LDFLAGS="-Wl,-read_only_relocs,suppress"
	;;
     *)
        DARWIN_LDFLAGS=""
	;;
esac
AC_SUBST(DARWIN_LDFLAGS)

199
dnl *** configure external libs ***
200

201
HAVE_FFMPEG_UNINSTALLED=1
202
203
204
205
206
207
208
209
210
211
212
213

AC_ARG_WITH(system-ffmpeg,
            [AC_HELP_STRING([--with-system-ffmpeg], [use system FFmpeg libraries])])

if test "x$with_system_ffmpeg" = "xyes"; then
  PKG_CHECK_MODULES(FFMPEG, libavutil libavcodec libavformat)
  PKG_CHECK_MODULES(POSTPROC, libavcodec libpostproc)
  saved_CPPFLAGS="$CPPFLAGS"
  CPPFLAGS="$CPPFLAGS $FFMPEG_CFLAGS"
  AC_CHECK_HEADERS([avi.h])
  CPPFLAGS="$saved_CPPFLAGS"
  AC_DEFINE([FFMPEG_SOURCE], ["system install"], [Describes where the FFmpeg libraries come from.])
214
215
  HAVE_FFMPEG_UNINSTALLED=0
  AC_MSG_NOTICE([Using system-installed FFMpeg code])
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
  AC_MSG_WARN([
  ======================================================================
   WARNING: you have chosen to build gst-ffmpeg against a random
   external version of ffmpeg instead of building it against the tested
   internal ffmpeg snapshot that is included with gst-ffmpeg.
   
   This is a very bad idea.  So bad in fact that words cannot express
   just how bad it is.  Suffice to say that it is BAD.
   
   The GStreamer developers cannot and will not support a gst-ffmpeg
   built this way.  Any bug reports that indicate there is an external
   version of ffmpeg involved will be closed immediately without further
   investigation.
   
   The reason such a setup can't be supported is that the ffmpeg API
   and ABI is in constant flux, yet there aren't any official releases
   of the ffmpeg library to develop against.  This makes it impossible
   to guarantee that gst-ffmpeg will work reliably, or even compile,
   with a randomly picked version ffmpeg.  Even if gst-ffmpeg compiles
   and superficially appears to work fine against your chosen external
   ffmpeg version, that might just not be the case on other systems, or
   even the same system at a later time, or when using decoders,
   encoders, demuxers or muxers that have not been tested.
   
   Please do not create or distribute binary packages of gst-ffmpeg
   that link against an external ffmpeg. Thank you!
  ======================================================================
  ])

  dnl No, this is not too extreme, we want people to see and read the above
  sleep 15
247
else
248
249
250
251
252
253

  source ./ffmpegrev 
  
  AC_MSG_NOTICE([Using ffmpeg revision $FFMPEG_REVISION])
  
  dnl libgstffmpeg.la: include dirs
254
255
  FFMPEG_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavformat \
                 -I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavutil \
256
                 -I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavcodec \
257
		 -I \$(top_srcdir)/gst-libs/ext/ffmpeg \
258
                 -Wno-deprecated-declarations"
259
260
261
262

  dnl libgstffmpeg.la: libs to statically link to        
  FFMPEG_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libavformat/libavformat.a \
               \$(top_builddir)/gst-libs/ext/ffmpeg/libavcodec/libavcodec.a \
263
               \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.a"
264
  dnl
265
266
267
  POSTPROC_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/ffmpeg/libpostproc	\
                   -I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavutil 	\
                   -I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavcodec 	\
268
                   -I \$(top_srcdir)/gst-libs/ext/ffmpeg 	\
269
                   -Wno-deprecated-declarations"
270
271
272
273
274

  dnl libgstpostproc.la: libs to statically link to
  POSTPROC_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libpostproc/libpostproc.a \
  		 \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.a"
  				 
275
276
277
  FFMPEG_SUBDIRS=gst-libs
  AC_DEFINE(HAVE_AVI_H)
  AC_DEFINE([FFMPEG_SOURCE], ["local snapshot"], [Describes where the FFmpeg libraries come from.])
278
  ac_configure_args="$ac_configure_args --disable-vhook --disable-ffserver --disable-ffplay --enable-postproc --enable-gpl --enable-static --disable-encoder=flac --disable-decoder=cavs --extra-cflags=-fPIC"
279
280
281
282
283
284
285
286
287
288
289
290
291
292
  case $host_os in
    # Unfortunately, in Mac OS 10.5 the current rev of ffmpeg builds
    # some non-PIC code into the .a file. See
    # http://trac.macosforge.org/projects/macports/ticket/13725 for more
    # info.
    darwin*) 
      ac_configure_args="$ac_configure_args --disable-mmx --disable-altivec"
      ;;
    *)
      # --disable-shared on macos turns on -mdynamic-no-pic, which we
      # can't have
      ac_configure_args="$ac_configure_args --disable-shared"
      ;;
  esac
293
294
295
  AC_SUBST(FFMPEG_CO_DIR)
  AC_SUBST(FFMPEG_SVN)
  AC_SUBST(FFMPEG_REVISION)
296
  AC_CONFIG_SUBDIRS(gst-libs/ext/ffmpeg)
297
  AC_MSG_NOTICE([Using included FFMpeg code])
298
fi
299

300
301
302
AC_SUBST(FFMPEG_CFLAGS)
AC_SUBST(FFMPEG_LIBS)
AC_SUBST(FFMPEG_SUBDIRS)
303
304
305
AC_SUBST(POSTPROC_CFLAGS)
AC_SUBST(POSTPROC_LIBS)
  
306
307
308
309
AC_DEFINE_UNQUOTED(HAVE_FFMPEG_UNINSTALLED, $HAVE_FFMPEG_UNINSTALLED,
                   [Defined if building against uninstalled FFmpeg source])
AM_CONDITIONAL(HAVE_FFMPEG_UNINSTALLED, test x$HAVE_FFMPEG_UNINSTALLED = x1)

310
311
AC_CONFIG_FILES(
Makefile
Christian Schaller's avatar
Christian Schaller committed
312
gst-ffmpeg.spec
313
314
ext/Makefile
ext/ffmpeg/Makefile
315
ext/libpostproc/Makefile
316
317
gst-libs/Makefile
gst-libs/ext/Makefile
318
docs/Makefile
319
docs/version.entities
320
docs/plugins/Makefile
321
322
common/Makefile
common/m4/Makefile
323
324
tests/Makefile
tests/check/Makefile
325
326
)
AC_OUTPUT
327