Commit 1a27ff33 authored by christophecvr's avatar christophecvr Committed by Stefan Sauer

mediainfo: update build setup

Fix intltool build setup to make it build on ubuntu 16.04 as well.
Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=776523
parent 9e2ca675
......@@ -12,7 +12,8 @@ test -n "$srcdir" || srcdir=$(dirname "$0")
test -n "$srcdir" || srcdir=.
(
cd "$srcdir" &&
AUTOPOINT='intltoolize --automake -c -f' autoreconf -fivm
AUTOPOINT='intltoolize --automake -c -f' autoreconf -fiv &&
test -f "po/Makefile.in.in" || intltoolize -c -f
) || exit
test -n "$NOCONFIGURE" || "$srcdir/configure" "$@"
# configure.ac
AC_INIT([gst-mediainfo], [0.1.1])
AC_PREREQ(2.62)
dnl initialize autoconf
dnl when going to/from release please set the nano (fourth number) right !
dnl releases only do Wall, cvs and prerelease does Werror too
AC_INIT(Gst-Mediainfo, 1.11.0.1,
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer,
gst-mediainfo)
AC_CONFIG_SRCDIR([src/mi.vala])
AC_CONFIG_HEADERS([config.h])
......@@ -13,19 +17,18 @@ AC_PROG_CC
AC_PROG_CC_STDC
AM_PROG_VALAC([0.7.0])
AC_PROG_INSTALL
AC_PROG_INTLTOOL([0.35])
IT_PROG_INTLTOOL([0.35])
PKG_PROG_PKG_CONFIG
pkg_modules="gee-0.8 gtk+-3.0 >= 3.0.0 gstreamer-1.0 >= 1.1.0 gstreamer-plugins-base-1.0 >= 1.1.0 gstreamer-pbutils-1.0 >= 1.1.0 gstreamer-video-1.0 >= 1.1.0"
MI_PACKAGES="--pkg gee-0.8 --pkg gtk+-3.0 --pkg gdk-x11-3.0 --pkg gstreamer-1.0 --pkg gstreamer-pbutils-1.0 --pkg gstreamer-video-1.0"
PKG_CHECK_MODULES([MI], [$pkg_modules])
AC_SUBST(MI_CFLAGS)
AC_SUBST(MI_LIBS)
AC_SUBST(MI_PACKAGES)
GETTEXT_PACKAGE=gst-mi
AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["$GETTEXT_PACKAGE"], [Gettext Package])
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Gettext Package])
AC_SUBST(GETTEXT_PACKAGE)
# AC_PROG_INTLTOOL is enough, the lines below caused:
# required file `./config.rpath' not found
......
bin_PROGRAMS = gst-mi
INCLUDES = \
AM_CPPFLAGS = \
-include config.h \
$(MI_CFLAGS) \
-DG_LOG_DOMAIN=\"gst-mi\" \
......@@ -8,7 +8,7 @@ INCLUDES = \
-DPKGDATADIR=\""$(pkgdatadir)"\" \
-DPKGLIBDIR=\""$(pkglibdir)"\"
VALAFLAGS = \
AM_VALAFLAGS = \
--vapidir=$(top_srcdir)/vapi --pkg config \
@MI_PACKAGES@
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment