Commit 8ba5dffb authored by Tim-Philipp Müller's avatar Tim-Philipp Müller 🐠

m4/gst-parser.m4: Need to use double square brackets again so m4 doesn't...

m4/gst-parser.m4: Need to use double square brackets again so m4 doesn't remove them (fixes #378931).

Original commit message from CVS:
* m4/gst-parser.m4:
Need to use double square brackets again so m4 doesn't remove them
(fixes #378931).
* m4/gst-args.m4:
Use double square brackets here as well, for the same reason.
parent 64f924f6
2007-01-08 Tim-Philipp Müller <tim at centricular dot net>
* m4/gst-parser.m4:
Need to use double square brackets again so m4 doesn't remove them
(fixes #378931).
* m4/gst-args.m4:
Use double square brackets here as well, for the same reason.
2007-01-05 Tim-Philipp Müller <tim at centricular dot net>
* m4/gst-parser.m4:
......
......@@ -95,7 +95,7 @@ AC_DEFUN([GST_ARG_GCOV],
[GCOV_CFLAGS="$GCOV_CFLAGS -ftest-coverage"],
true)
dnl remove any -O flags - FIXME: is this needed ?
GCOV_CFLAGS=`echo "$GCOV_CFLAGS" | sed -e 's/-O[0-9]*//g'`
GCOV_CFLAGS=`echo "$GCOV_CFLAGS" | sed -e 's/-O[[0-9]]*//g'`
dnl libtool 1.5.22 and lower strip -fprofile-arcs from the flags
dnl passed to the linker, which is a bug; -fprofile-arcs implicitly
dnl links in -lgcov, so we do it explicitly here for the same effect
......
......@@ -9,7 +9,7 @@ AC_DEFUN([GST_BISON_CHECK],
dnl check bison version
bison_min_version=1.35
bison_version=`$BISON_PATH --version | head -n 1 | sed 's/^.*) //' | sed 's/[a-zA-Z]*$//' | cut -d' ' -f1`
bison_version=`$BISON_PATH --version | head -n 1 | sed 's/^.*) //' | sed 's/[[a-zA-Z]]*$//' | cut -d' ' -f1`
AC_MSG_CHECKING([bison version $bison_version >= $bison_min_version])
if perl -w <<EOF
......@@ -34,7 +34,7 @@ AC_DEFUN([GST_FLEX_CHECK],
dnl check flex version
flex_min_version=2.5.6
flex_version=`$FLEX_PATH --version | head -n 1 | sed 's/^.* //' | sed 's/[a-zA-Z]*$//' | cut -d' ' -f1`
flex_version=`$FLEX_PATH --version | head -n 1 | sed 's/^.* //' | sed 's/[[a-zA-Z]]*$//' | cut -d' ' -f1`
AC_MSG_CHECKING([flex version $flex_version >= $flex_min_version])
if perl -w <<EOF
(\$min_version_major, \$min_version_minor, \$min_version_micro ) = "$flex_min_version" =~ /(\d+)\.(\d+)\.(\d+)/;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment