Commit 52bba139 authored by Julien Moutte Moutte's avatar Julien Moutte Moutte

m4/gst-check.m4: I know Thomas will kill me but this ifelse statement seems...

m4/gst-check.m4: I know Thomas will kill me but this ifelse statement seems incorrect as it is always setting require...

Original commit message from CVS:
2005-10-17  Julien MOUTTE  <julien@moutte.net>

* m4/gst-check.m4: I know Thomas will kill me but this
ifelse statement seems incorrect as it is always setting
required to "yes". With this one it seems to work. Fixes
build of gst-plugins-base on my setup where gstreamer-check
is definitely not present/required.
parent 30c7a70b
2005-10-17 Julien MOUTTE <julien@moutte.net>
* m4/gst-check.m4: I know Thomas will kill me but this
ifelse statement seems incorrect as it is always setting
required to "yes". With this one it seems to work. Fixes
build of gst-plugins-base on my setup where gstreamer-check
is definitely not present/required.
2005-10-18 Stefan Kost <ensonic@users.sf.net>
* gtk-doc.mak:
......
......@@ -19,7 +19,7 @@ AC_DEFUN([GST_CHECK_MODULES],
module=[$2]
minver=[$3]
name="[$4]"
required=ifelse([$5], [$5], "yes") dnl fail by default
required=ifelse("[$5]", "no", "no", "yes") dnl required by default
PKG_CHECK_MODULES([$1], $module >= $minver,
HAVE_[$1]="yes", HAVE_[$1]="no")
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment