Commit 3fec971d authored by Andres Gomez's avatar Andres Gomez Committed by Emil Velikov

travis: keep meson version below 0.45.0

Recently Meson upgraded to 0.45.0 and it needs python 3.5+, which is
not available in Trusty.

Cc: Eric Engestrom <eric.engestrom@imgtec.com>
Cc: Dylan Baker <dylan@pnwbakers.com>
Cc: Emil Velikov <emil.velikov@collabora.com>
Cc: Jon Turney <jon.turney@dronecode.org.uk>
Signed-off-by: Andres Gomez's avatarAndres Gomez <agomez@igalia.com>
Reviewed-by: default avatarEmil Velikov <emil.velikov@collabora.com>
Reviewed-by: Eric Engestrom's avatarEric Engestrom <eric.engestrom@imgtec.com>
Reviewed-by: Dylan Baker's avatarDylan Baker <dylan@pnwbakers.com>
(cherry picked from commit 72552012)
parent 9f86aee1
......@@ -432,10 +432,11 @@ before_install:
install:
- pip2 install --user mako
# Install the latest meson from pip, since the version in the ubuntu repos is
# often quite old.
# Install a more modern meson from pip, since the version in the
# ubuntu repos is often quite old. Avoid >=0.45.0 as it needs python
# 3.5+
- if test "x$BUILD" = xmeson; then
pip3 install --user meson;
pip3 install --user "meson<0.45.0";
fi
# Since libdrm gets updated in configure.ac regularly, try to pick up the
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment